summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2016-10-26 13:24:09 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2016-10-26 13:24:09 +0300
commit26676ad6fabb66c7f1708a0b738a079c9ae9d389 (patch)
tree3312722b5341731cb5c4c29e7b58c0500b1e16dd /sys-power
parentwww-apps/websvn: x86 stable wrt bug #552684 (diff)
downloadgentoo-26676ad6fabb66c7f1708a0b738a079c9ae9d389.tar.gz
gentoo-26676ad6fabb66c7f1708a0b738a079c9ae9d389.tar.bz2
gentoo-26676ad6fabb66c7f1708a0b738a079c9ae9d389.zip
sys-power/hibernate-script: fix openrc executable
Bug: 597108 Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/hibernate-script/Manifest2
-rw-r--r--sys-power/hibernate-script/files/hibernate-script-2.0-init.d.patch56
-rw-r--r--sys-power/hibernate-script/hibernate-script-2.0-r6.ebuild4
3 files changed, 3 insertions, 59 deletions
diff --git a/sys-power/hibernate-script/Manifest b/sys-power/hibernate-script/Manifest
index 02d806959c94..901a0a381d0d 100644
--- a/sys-power/hibernate-script/Manifest
+++ b/sys-power/hibernate-script/Manifest
@@ -1,2 +1,2 @@
-DIST hibernate-script-2.0-patches-4.tar.bz2 4209 SHA256 525260253be33ee6115d733ceef84de86a9161219c8503c106fa75d62e0ff2c3 SHA512 7fadffe0b749b202c3e26795a8fdbf4861649893132816fed4714543b9caab0185d0005ec02c9e9484ba7392a13ed90722e6beeb4ecf96e0d92cc6918a6cb343 WHIRLPOOL 2b5d276ce1843d2627f506902137945ec45f7be313538c5da48367ab4f523dec59aec5eedb2961446b967e67460eaa7f741f7f806485e4c40bac8b55012fd275
+DIST hibernate-script-2.0-patches-5.tar.bz2 4203 SHA256 592f6069ed18aa23feb93286ec2bd8c0b8577e977647591cc4d3f1636499c219 SHA512 9e9c45c8f9bfde9bfb7d2ab229e355e635ae2f98cfdefa964c07401cdef5e57d0c58976bd491f82a3b9204af213c82f840e0a9b794b2869f2dfe7783dbdb4970 WHIRLPOOL 1df9605be7d8bf4b3f728738420ab5cfaaeb55d566e1f78227f7fc54b977c5469874b008f57a46d866795a3b11d019c16bb24f92f04c37eb9515d031a75e3626
DIST hibernate-script-2.0.tar.gz 84453 SHA256 d04597473a50c6ac072e3a4c22f173a7234a97bc2a39e460e56c5d3d985a6545 SHA512 625efdf8bd8561dd9ab93c09436f2fb93edef2fbb0fb2d259727bacffab0b7bd4a6c99d445131390883be75658f6dd28f329fdaf4f03a7d218c0021223ac1a1e WHIRLPOOL 8dab0108063b0d74d49fd075fdba7c96db7eeb8ebab5054329578b3dfe7adeb0d048db6cedfc238ba374bfa97d689eb8e08eb270ab72d861904487b7dc04dc21
diff --git a/sys-power/hibernate-script/files/hibernate-script-2.0-init.d.patch b/sys-power/hibernate-script/files/hibernate-script-2.0-init.d.patch
deleted file mode 100644
index 9d0157d3f6fb..000000000000
--- a/sys-power/hibernate-script/files/hibernate-script-2.0-init.d.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-diff -Nru hibernate-script-2.0.vanilla/init.d/hibernate-cleanup.sh hibernate-script-2.0/init.d/hibernate-cleanup.sh
---- hibernate-script-2.0.vanilla/init.d/hibernate-cleanup.sh 2009-05-01 23:03:41.000000000 +0100
-+++ hibernate-script-2.0/init.d/hibernate-cleanup.sh 2009-05-01 23:03:55.000000000 +0100
-@@ -1,4 +1,4 @@
--#!/bin/sh
-+#!/sbin/openrc-run
-
- # This script invalidates any stale swsusp and TuxOnIce images. It
- # searches all swap partitions on your machine, as well as TuxOnIce's
-@@ -91,27 +91,30 @@
-
-
- msg_status() {
-- echo -n "$1"
-+ einfon "$1"
- }
-
- msg() {
-- echo "$1"
-+ einfo "$1"
- }
-
--case "$1" in
--start)
-- msg_status "Invalidating stale software suspend images... "
-+opts="reload"
-+
-+depend() {
-+ after modules
-+ before localmount
-+}
-+
-+start() {
-+ ebegin "Invalidating stale software suspend images"
- do_start
-- msg "done."
-- ;;
--stop)
-+ eend $?
-+}
-+
-+stop() {
- do_stop
-- ;;
--restart|force-reload)
-- do_reload
-- ;;
--*)
-- msg "Usage: /etc/init.d/hibernate {start|stop|restart|force-reload}"
--esac
-+}
-
--exit 0
-+reload() {
-+ do_reload
-+}
diff --git a/sys-power/hibernate-script/hibernate-script-2.0-r6.ebuild b/sys-power/hibernate-script/hibernate-script-2.0-r6.ebuild
index 5e8cc089a76d..f01aab2ac0dd 100644
--- a/sys-power/hibernate-script/hibernate-script-2.0-r6.ebuild
+++ b/sys-power/hibernate-script/hibernate-script-2.0-r6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -6,7 +6,7 @@ EAPI=5
inherit eutils
-PATCH_VERSION="4"
+PATCH_VERSION="5"
DESCRIPTION="Hibernate script supporting multiple suspend methods"
HOMEPAGE="http://www.tuxonice.net/"