summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-03-07 12:57:52 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-07 12:57:52 +0100
commit273cddf01d7510523e0451c20d51a5e332ac5367 (patch)
tree0591673dfe4574652509573dc359bb97aec9f7f5 /sys-power
parentsys-libs/musl-nscd: migrate to tmpfiles.eclass (diff)
downloadgentoo-273cddf01d7510523e0451c20d51a5e332ac5367.tar.gz
gentoo-273cddf01d7510523e0451c20d51a5e332ac5367.tar.bz2
gentoo-273cddf01d7510523e0451c20d51a5e332ac5367.zip
sys-power/apcupsd: migrate to tmpfiles.eclass
Closes: https://bugs.gentoo.org/740634 Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/apcupsd/apcupsd-3.14.13.ebuild6
-rw-r--r--sys-power/apcupsd/apcupsd-3.14.14-r2.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/sys-power/apcupsd/apcupsd-3.14.13.ebuild b/sys-power/apcupsd/apcupsd-3.14.13.ebuild
index b6e3eb60c4f7..0b3e17414135 100644
--- a/sys-power/apcupsd/apcupsd-3.14.13.ebuild
+++ b/sys-power/apcupsd/apcupsd-3.14.13.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit eutils linux-info flag-o-matic systemd udev
+inherit eutils linux-info flag-o-matic systemd udev tmpfiles
DESCRIPTION="APC UPS daemon with integrated tcp/ip remote shutdown"
HOMEPAGE="http://www.apcupsd.org/"
@@ -93,7 +93,7 @@ src_install() {
newinitd "${FILESDIR}/${PN}.powerfail.init" "${PN}".powerfail
systemd_dounit "${FILESDIR}"/${PN}.service
- systemd_dotmpfilesd "${FILESDIR}"/${PN}-tmpfiles.conf
+ dotmpfiles "${FILESDIR}"/${PN}-tmpfiles.conf
# remove hal settings, we don't really want to have it around still.
rm -r "${D}"/usr/share/hal
diff --git a/sys-power/apcupsd/apcupsd-3.14.14-r2.ebuild b/sys-power/apcupsd/apcupsd-3.14.14-r2.ebuild
index 4390e39bda52..d3d3a89e00d8 100644
--- a/sys-power/apcupsd/apcupsd-3.14.14-r2.ebuild
+++ b/sys-power/apcupsd/apcupsd-3.14.14-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit linux-info flag-o-matic systemd udev
+inherit linux-info flag-o-matic systemd udev tmpfiles
DESCRIPTION="APC UPS daemon with integrated tcp/ip remote shutdown"
HOMEPAGE="http://www.apcupsd.org/"
@@ -93,7 +93,7 @@ src_install() {
newinitd "${FILESDIR}/${PN}.powerfail.init" "${PN}".powerfail
systemd_dounit "${FILESDIR}"/${PN}.service
- systemd_dotmpfilesd "${FILESDIR}"/${PN}-tmpfiles.conf
+ dotmpfiles "${FILESDIR}"/${PN}-tmpfiles.conf
# remove hal settings, we don't really want to have it around still.
rm -r "${D}"/usr/share/hal || die