summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-09-27 22:01:07 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-09-27 22:01:07 +0200
commit4f3b58d0f2e1626a641b1c56b6fced84ba3289fb (patch)
treeb3841b10e85c4915fa7d87b8c01cef3dc688ffa6 /sys-power
parentdev-php/igbinary: Drop old (diff)
downloadgentoo-4f3b58d0f2e1626a641b1c56b6fced84ba3289fb.tar.gz
gentoo-4f3b58d0f2e1626a641b1c56b6fced84ba3289fb.tar.bz2
gentoo-4f3b58d0f2e1626a641b1c56b6fced84ba3289fb.zip
sys-power/acpi_call: bump to version 1.2.2
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/acpi_call/Manifest1
-rw-r--r--sys-power/acpi_call/acpi_call-1.2.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-power/acpi_call/Manifest b/sys-power/acpi_call/Manifest
index caf7217e1c07..44950a061461 100644
--- a/sys-power/acpi_call/Manifest
+++ b/sys-power/acpi_call/Manifest
@@ -1 +1,2 @@
DIST acpi_call-1.2.1.tar.gz 12340 BLAKE2B e113f8c150c8e2f4f75ca1dd81cc4399f24bedcd716c9158561e8cb9f5e63e77cade18e6543ade4ec383690bf7041a583e297948789773db8ad9b63a957e61e8 SHA512 91553cf70a6b0173a6bfec38fcfb62ecd17614c91a888933704bb57d788592ce6981b01fb7c5e4bb8efdbe7fe229860c9f2be4b549dd71b232704c8bf0b3cfee
+DIST acpi_call-1.2.2.tar.gz 12403 BLAKE2B 3195ec7e4d6189abdbb1409914d97d481f63ec79ec89a2ab630120ea99aabf8ca5890c500149a386a4a661d17e58387a6b252b625b6abadef1d977691156745e SHA512 3916a211bcc4a2435c6ba9664b1c86d8ab587c052a03e6edccd00fd7d01c6a756003dcc146e22e2cf688795600589c8cac1d83774c989794dcadc91f5caa2b5e
diff --git a/sys-power/acpi_call/acpi_call-1.2.2.ebuild b/sys-power/acpi_call/acpi_call-1.2.2.ebuild
new file mode 100644
index 000000000000..781cbf2fc3af
--- /dev/null
+++ b/sys-power/acpi_call/acpi_call-1.2.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info linux-mod
+
+DESCRIPTION="A linux kernel module that enables calls to ACPI"
+HOMEPAGE="https://github.com/nix-community/acpi_call"
+SRC_URI="https://github.com/nix-community/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+BUILD_TARGETS="default"
+CONFIG_CHECK="ACPI"
+MODULE_NAMES="acpi_call(misc:${S})"
+
+src_compile() {
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+
+ if use examples; then
+ insinto /usr/share/acpi_call
+ doins examples/*.sh
+ fi
+}