summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-02-11 15:00:17 +0800
committerYixun Lan <dlan@gentoo.org>2021-02-11 15:02:01 +0800
commit6080ba56a1f0175341ff8333a6e198e6b6232171 (patch)
treeb076405856b6378b7ddf7ed8ab6605e2955a2591 /sys-power
parentnet-analyzer/sslscan: add 2.0.7 (diff)
downloadgentoo-6080ba56a1f0175341ff8333a6e198e6b6232171.tar.gz
gentoo-6080ba56a1f0175341ff8333a6e198e6b6232171.tar.bz2
gentoo-6080ba56a1f0175341ff8333a6e198e6b6232171.zip
sys-power/thermald: version bump, 2.4.2
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/thermald/Manifest1
-rw-r--r--sys-power/thermald/thermald-2.4.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/sys-power/thermald/Manifest b/sys-power/thermald/Manifest
index f5a8f624523e..6e2a5a4b9587 100644
--- a/sys-power/thermald/Manifest
+++ b/sys-power/thermald/Manifest
@@ -1,2 +1,3 @@
DIST thermald-2.3.tar.gz 452790 BLAKE2B caef87d670b14bfa0dbe6ca4873ebea4b0a9960a9bad48ddb10abb348e25cafdbdf5dad831a1c3ad38e71ab61d7f123df99046dec1e5ce2c32be506bc4b1312f SHA512 0d722c35e3638bb917994b8a123e1226b737b120f0946cfc604eb3bb4bd501121b1f196833f8cb3aceee73a8bb3566ef1d176d81143b84423f89d20966e91ed8
DIST thermald-2.4.1.tar.gz 455735 BLAKE2B ee4d6bc590bc50639c0b19adbba7e243358174a837b2ff155dea060b1cd09171d4fb77b18b785dc9f64a633f680358cb1d7b36e3bd438e5267e0a0a27e18497e SHA512 2dab7d57e028037208034ab4be95dc138ce028d4a47a0151c69816e1502065d801d52990641544b5d246144e654c15c663fa78af6cea094cf9a107f2fb29c1ef
+DIST thermald-2.4.2.tar.gz 455797 BLAKE2B 5be01fa67defe738d2e9109388ab440ee93fea63e2fb56c2f5294095b14077330f1af4cba454e0f39bde69726f358513bec123f1eb7815afac469fb2385b6c9a SHA512 96d5cb9bf4f04b6ec5763d499416c246077b2d6dbc623de3fbb2b1fb8dc8b702d417852119240496f28f0a69c52be1b2a47e5d9ee7e952a123c621bda4d809ef
diff --git a/sys-power/thermald/thermald-2.4.2.ebuild b/sys-power/thermald/thermald-2.4.2.ebuild
new file mode 100644
index 000000000000..2683a9652ea6
--- /dev/null
+++ b/sys-power/thermald/thermald-2.4.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools out-of-source systemd
+
+DESCRIPTION="Thermal daemon for Intel architectures"
+HOMEPAGE="https://01.org/linux-thermal-daemon https://github.com/intel/thermal_daemon"
+SRC_URI="https://github.com/intel/thermal_daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/dbus-glib:=
+ dev-libs/glib:=
+ dev-libs/libxml2:=
+ dev-libs/libevdev
+ sys-power/upower
+ sys-apps/dbus:="
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+ dev-util/glib-utils"
+
+S=${WORKDIR}/thermal_daemon-${PV}
+DOCS=( thermal_daemon_usage.txt README.txt )
+
+src_prepare() {
+ sed -i -e "/group=/s/power/wheel/g" \
+ data/org.freedesktop.thermald.conf || die
+
+ default
+ eautoreconf
+}
+
+my_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-werror \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ rm -rf "${ED}"/etc/init || die
+ doinitd "${FILESDIR}"/thermald
+}
+
+pkg_postinst() {
+ if ! has_version sys-power/dptfxtract; then
+ elog "dptfxtract can be used to generate a more specific"
+ elog "thermald configuration for your system"
+ fi
+}