summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoh Matsuura <gh.cions@gmail.com>2022-04-10 17:59:06 +0900
committerYixun Lan <dlan@gentoo.org>2022-04-10 21:32:49 +0800
commit80a8fff52c054ef4fac175414a7440b03d21134d (patch)
treed984ddc26cca134d577fd7cf86c0ee954a304cf9 /sys-power
parentkde-apps/kdenlive: Keyword 21.12.3 riscv, #837059 (diff)
downloadgentoo-80a8fff52c054ef4fac175414a7440b03d21134d.tar.gz
gentoo-80a8fff52c054ef4fac175414a7440b03d21134d.tar.bz2
gentoo-80a8fff52c054ef4fac175414a7440b03d21134d.zip
sys-power/thermald: Fix tdrundir
Use /run instead of /var/lib/run for runtime state directory Closes: https://github.com/gentoo/gentoo/pull/24970 Signed-off-by: Joh Matsuura <gh.cions@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/thermald/thermald-2.4.8-r1.ebuild (renamed from sys-power/thermald/thermald-2.4.8.ebuild)4
1 files changed, 4 insertions, 0 deletions
diff --git a/sys-power/thermald/thermald-2.4.8.ebuild b/sys-power/thermald/thermald-2.4.8-r1.ebuild
index 2a2134ef6d2f..608411e5ceb4 100644
--- a/sys-power/thermald/thermald-2.4.8.ebuild
+++ b/sys-power/thermald/thermald-2.4.8-r1.ebuild
@@ -32,6 +32,9 @@ src_prepare() {
sed -i -e "/group=/s/power/wheel/g" \
data/org.freedesktop.thermald.conf || die
+ sed -i -e '/tdrundir/s@\$localstatedir/run@\$runstatedir@' \
+ configure.ac || die
+
default
eautoreconf
}
@@ -39,6 +42,7 @@ src_prepare() {
my_src_configure() {
ECONF_SOURCE="${S}" econf \
--disable-werror \
+ --runstatedir="${EPREFIX}"/run \
--with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
}