summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-11-07 13:20:40 -0500
committerZero_Chaos <zerochaos@gentoo.org>2018-11-07 13:20:53 -0500
commit8936b8d10e3758ed4142e6b0a1834cf7a560293f (patch)
tree95c0f7f7cc0c92861c4c58462106538eca41c47d /sys-power
parentapp-benchmarks/cpuburn: bump to EAPI=7 (diff)
downloadgentoo-8936b8d10e3758ed4142e6b0a1834cf7a560293f.tar.gz
gentoo-8936b8d10e3758ed4142e6b0a1834cf7a560293f.tar.bz2
gentoo-8936b8d10e3758ed4142e6b0a1834cf7a560293f.zip
sys-power/thermald: fixes bug #670624
apologies if the bump isn't correct, but I wasn't sure if this might cause a runtime issue on other arches which successfully built and the package takes 20 seconds to build Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/thermald/files/thermald-1.8-x86-fix.patch31
-rw-r--r--sys-power/thermald/thermald-1.8-r1.ebuild (renamed from sys-power/thermald/thermald-1.8.ebuild)1
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-power/thermald/files/thermald-1.8-x86-fix.patch b/sys-power/thermald/files/thermald-1.8-x86-fix.patch
new file mode 100644
index 000000000000..e944003b79b7
--- /dev/null
+++ b/sys-power/thermald/files/thermald-1.8-x86-fix.patch
@@ -0,0 +1,31 @@
+From bb7631163c8f3f44d0dc83690765cdb799664fd5 Mon Sep 17 00:00:00 2001
+From: Anuj Mittal <anuj.mittal@intel.com>
+Date: Wed, 26 Sep 2018 10:34:15 +0800
+Subject: [PATCH] Use correct format specifier for size_t
+
+%zu instead of %lu, otherwise on 32 bit:
+
+| ../git/src/thd_zone.cpp: In member function 'void cthd_zone::sort_and_update_poll_trip()':
+| ../git/src/thd_zone.cpp:106:16: error: format '%lu' expects argument of type 'long unsigned int', but argument 4 has type 'std::vector<cthd_trip_point>::size_type' {aka 'unsigned int'} [-Werror=format=]
+| thd_log_debug("sort_and_update_poll_trip: trip_points_size =%lu\n",
+| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+| trip_points.size());
+
+Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
+---
+ src/thd_zone.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/thd_zone.cpp b/src/thd_zone.cpp
+index b7edf9e..cb7b8e8 100644
+--- a/src/thd_zone.cpp
++++ b/src/thd_zone.cpp
+@@ -103,7 +103,7 @@ int cthd_zone::read_user_set_psv_temp() {
+ }
+
+ void cthd_zone::sort_and_update_poll_trip() {
+- thd_log_debug("sort_and_update_poll_trip: trip_points_size =%lu\n",
++ thd_log_debug("sort_and_update_poll_trip: trip_points_size =%zu\n",
+ trip_points.size());
+ if (trip_points.size()) {
+ unsigned int polling_trip = 0;
diff --git a/sys-power/thermald/thermald-1.8.ebuild b/sys-power/thermald/thermald-1.8-r1.ebuild
index 525bb27d6f06..e578d903b8eb 100644
--- a/sys-power/thermald/thermald-1.8.ebuild
+++ b/sys-power/thermald/thermald-1.8-r1.ebuild
@@ -26,6 +26,7 @@ S=${WORKDIR}/thermal_daemon-${PV}
DOCS=( thermal_daemon_usage.txt README.txt )
src_prepare() {
+ epatch "${FILESDIR}"/"${P}"-x86-fix.patch
default
eautoreconf
}