summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-05-10 17:51:08 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-05-10 18:22:12 +0200
commit94833a31987a268ce07ecc792f6cc54866d2daea (patch)
treed21679f4b37b4f480c4d7b93df6f1dce498663b4 /sys-power
parentnet-vpn/networkmanager-strongswan: bump to version 1.5.1 (diff)
downloadgentoo-94833a31987a268ce07ecc792f6cc54866d2daea.tar.gz
gentoo-94833a31987a268ce07ecc792f6cc54866d2daea.tar.bz2
gentoo-94833a31987a268ce07ecc792f6cc54866d2daea.zip
sys-power/acpi_call: fix qa warning
Also bumped to EAPI=7. Closes: https://bugs.gentoo.org/694400 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/acpi_call/acpi_call-3.17-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-power/acpi_call/acpi_call-3.17-r1.ebuild b/sys-power/acpi_call/acpi_call-3.17-r1.ebuild
new file mode 100644
index 000000000000..87ae13124e96
--- /dev/null
+++ b/sys-power/acpi_call/acpi_call-3.17-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info linux-mod
+
+HOMEPAGE="https://github.com/teleshoes/acpi_call"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/teleshoes/acpi_call.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/teleshoes/acpi_call/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A kernel module that enables you to call ACPI methods"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+BUILD_TARGETS="default"
+CONFIG_CHECK="ACPI"
+MODULE_NAMES="acpi_call(misc:${S})"
+
+PATCHES=(
+ "${FILESDIR}/${P}-linux-4.12.patch"
+ "${FILESDIR}/${P}-linux-4.14.patch"
+ "${FILESDIR}/${P}-linux-5.6.patch"
+)
+
+src_compile() {
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+ linux-mod_src_compile
+}