summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2022-01-31 22:56:52 +0800
committerYixun Lan <dlan@gentoo.org>2022-01-31 22:56:52 +0800
commit9ddb5b558d758f86de426177b669c09b2365230a (patch)
tree846eccfa7b60ebce576068ef662b2da16d8d4755 /sys-power
parentsys-apps/tuned: drop old (diff)
downloadgentoo-9ddb5b558d758f86de426177b669c09b2365230a.tar.gz
gentoo-9ddb5b558d758f86de426177b669c09b2365230a.tar.bz2
gentoo-9ddb5b558d758f86de426177b669c09b2365230a.zip
sys-power/thermald: version bump 2.4.8
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/thermald/Manifest1
-rw-r--r--sys-power/thermald/thermald-2.4.8.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-power/thermald/Manifest b/sys-power/thermald/Manifest
index acf947c2785f..2605cd1a3a7c 100644
--- a/sys-power/thermald/Manifest
+++ b/sys-power/thermald/Manifest
@@ -1,2 +1,3 @@
DIST thermald-2.4.6.tar.gz 455905 BLAKE2B 0e3eae24bd4de8f7adc9cb8cc6dec83907d8e8240bec87d752e4502c923e7b407546204af474fe32fa43ba85a60ba51bd3dc6f1ce7cf3a62dd60dc5b0235ed52 SHA512 e337b00ec7f4fa565927f047dbb17dc05b8513850f2488dd6cfc838e5123938fbfe7c39464fffb77c100073edfca9ea51708680eaa2cba537470326df9508d3a
DIST thermald-2.4.7.tar.gz 457290 BLAKE2B 2c546175181383c21d95345e4884e5d476a47b2c5f2e1dc379add5c340bd9f421567b7c391b6002e05e3ad793ba2f563d2eca7913f0688b53a8565f52da58fbf SHA512 26b09a18d40812705d277416752f7afd0962f0562d9701c9072140089b869c328f6b0caaa08744a660cd83b6a0313098a07aef11e1a2b371a81d2e8014c38887
+DIST thermald-2.4.8.tar.gz 457365 BLAKE2B a200eba847785ad4a99e229c10574ad99b0874ef14e8b14d5190e12090ae5f4577461743ac1993a1bdb28de85100b509c8affc7ba3426a61b9cba95ea14d2686 SHA512 6e81eb25c274f1ef6e8dcb975cfab23dab9e6d29dcd38d10085d47bbf7161f3d3b0f5159d8935ff8d2c0eba99c88fac2feb9e8cef906b6afacba08a57026300d
diff --git a/sys-power/thermald/thermald-2.4.8.ebuild b/sys-power/thermald/thermald-2.4.8.ebuild
new file mode 100644
index 000000000000..2a2134ef6d2f
--- /dev/null
+++ b/sys-power/thermald/thermald-2.4.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools out-of-source systemd
+
+DESCRIPTION="Thermal daemon for Intel architectures"
+HOMEPAGE="https://01.org/linux-thermal-daemon https://github.com/intel/thermal_daemon"
+SRC_URI="https://github.com/intel/thermal_daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/dbus-glib:=
+ dev-libs/glib:=
+ dev-libs/libxml2:=
+ dev-libs/libevdev
+ sys-power/upower
+ sys-apps/dbus:="
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+ dev-util/glib-utils"
+
+S=${WORKDIR}/thermal_daemon-${PV}
+DOCS=( thermal_daemon_usage.txt README.txt )
+
+src_prepare() {
+ sed -i -e "/group=/s/power/wheel/g" \
+ data/org.freedesktop.thermald.conf || die
+
+ default
+ eautoreconf
+}
+
+my_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-werror \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ rm -rf "${ED}"/etc/init || die
+ doinitd "${FILESDIR}"/thermald
+}