summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2015-12-02 11:42:52 -0500
committerZero_Chaos <zerochaos@gentoo.org>2015-12-02 11:50:13 -0500
commite04e64a094273ec1768537cdfad71e3ff5631d47 (patch)
tree816e21f38b99c209f31a1874715a60ba1645987d /sys-power
parentdev-java/xerces: EAPI 5 version bump. (diff)
downloadgentoo-e04e64a094273ec1768537cdfad71e3ff5631d47.tar.gz
gentoo-e04e64a094273ec1768537cdfad71e3ff5631d47.tar.bz2
gentoo-e04e64a094273ec1768537cdfad71e3ff5631d47.zip
sys-power/powertop: version bump for bug #565832 thanks to Joe Konno
Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/powertop/Manifest1
-rw-r--r--sys-power/powertop/powertop-2.8.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/sys-power/powertop/Manifest b/sys-power/powertop/Manifest
index 611bb61d0b25..7e2205674a00 100644
--- a/sys-power/powertop/Manifest
+++ b/sys-power/powertop/Manifest
@@ -2,3 +2,4 @@ DIST powertop-1.13.tar.gz 104675 SHA256 2bc866089496877dd26d2d316ad5763ab8ecb5e2
DIST powertop-2.5.tar.gz 635979 SHA256 8b2c08a555d79e1c428863470c41cb023971d74ba4801d80a05e35adeec23c0b SHA512 696629fb6f5d0164da3ec2b259780dc635abc661de859e5e908debd3872c9a82024c0cc2dd8210c4cd1cf5586bf4238e31c3af29266f6a8ed8d90b1d876f04d8 WHIRLPOOL 5940b15ea4c5f09809e9a8febc11b1abe680df04469d75889c3a0cc0935a8c9d578d1f7c4ecaf2507cda74d574696a61b3bef21c6e30e9c768c09abf03436bcf
DIST powertop-2.6.tar.gz 3024009 SHA256 3024c2b13c8f32cdac0b0ea9359eb5668dc9bd11776cf063481daa878533d1ee SHA512 7c44b9c49f74d0f415d0332b60629940e05cf1c9170a9a7b98427da630c25c0cc9c8ece49e059ec8c665847ff03fa8a341e0cf8f7ca792d889f2c52a39ddbb62 WHIRLPOOL eaa6e05d2fdb3050eb3a37f39fb5d760a8d3d91461b8c6f0ae825138080a0dd8a532e490a71246d62d2e340e3820b402d761a1331a6e7b6bc23db116c98cf0d9
DIST powertop-2.7.tar.gz 654329 SHA256 8d4b1490e2baad4467c0ded3c423db4472dcbf7b2dd8f8f2a928f54047c678ca SHA512 7a69bee4dd5330d9d5d6da9c47615337cdde27eb1eeb3ffc75297df1a61b5ced9f2ee94684680154e71c0c46fac72e5485cadf7a43e943d8087b1d7b4f33f59d WHIRLPOOL b2323b3222fa45ff1874cca9f2a3121aebd54d4dd9c89a31f7299fac15e30013ae3103f79759e86368efdba528eb3a2f166359cbe15d97022166abc16e6fddad
+DIST powertop-2.8.tar.gz 670000 SHA256 a87b563f73106babfa3e74dcf92f252938c061e309ace20a361358bbfa579c5a SHA512 253d0e15f0972cf8639735c510f4884d49a0da76c31dd2f39603e2297e6c6f0b9fa283c7b3cb04a431c91f8296275c0adaecc4c3e9ea132c0c31064f7f432c80 WHIRLPOOL 87b859b76395d6b1b380c7459b0d918713e94e8fc4ac40fde8b82f2112dec2df3caffb645b082cedd0bba5c232555de26e81fbe8dd3041875c32c864650ef132
diff --git a/sys-power/powertop/powertop-2.8.ebuild b/sys-power/powertop/powertop-2.8.ebuild
new file mode 100644
index 000000000000..b558811bb939
--- /dev/null
+++ b/sys-power/powertop/powertop-2.8.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils linux-info
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/fenrus75/powertop.git"
+ inherit git-2 autotools
+ SRC_URI=""
+else
+ SRC_URI="https://01.org/sites/default/files/downloads/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="tool that helps you find what software is using the most power"
+HOMEPAGE="https://01.org/powertop/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls unicode X"
+
+COMMON_DEPEND="
+ dev-libs/libnl:3
+ sys-apps/pciutils
+ sys-libs/ncurses[unicode?]
+"
+
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ X? ( x11-apps/xset )
+ virtual/libintl
+"
+
+DOCS=( TODO README )
+
+pkg_setup() {
+ CONFIG_CHECK="
+ ~X86_MSR
+ ~DEBUG_FS
+ ~PERF_EVENTS
+ ~TRACEPOINTS
+ ~NO_HZ
+ ~HIGH_RES_TIMERS
+ ~HPET_TIMER
+ ~CPU_FREQ_STAT
+ ~CPU_FREQ_GOV_ONDEMAND
+ ~FTRACE
+ ~BLK_DEV_IO_TRACE
+ ~TIMER_STATS
+ ~TRACING
+ "
+ ERROR_KERNEL_X86_MSR="X86_MSR is not enabled in the kernel, you almost certainly need it"
+ ERROR_KERNEL_DEBUG_FS="DEBUG_FS is not enabled in the kernel, you almost certainly need it"
+ ERROR_KERNEL_PERF_EVENTS="PERF_EVENTS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_TRACEPOINTS="TRACEPOINTS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_NO_HZ="NO_HZ should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_HIGH_RES_TIMERS="HIGH_RES_TIMERS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
+ ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"
+ ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_TRACING="TRACING should be enabled in the kernel for full powertop function"
+ linux-info_pkg_setup
+ if linux_config_exists; then
+ if kernel_is -lt 3 7 0; then
+ if linux_chkconfig_present SND_HDA_INTEL; then
+ CONFIG_CHECK="~SND_HDA_POWER_SAVE"
+ ERROR_KERNEL_SND_HDA_POWER_SAVE="SND_HDA_POWER_SAVE should be enabled in the kernel for full powertop function"
+ check_extra_config
+ fi
+ fi
+ if kernel_is -lt 3 9 0; then
+ CONFIG_CHECK="~EVENT_POWER_TRACING_DEPRECATED"
+ ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
+ check_extra_config
+ fi
+ if kernel_is -lt 3 19; then
+ CONFIG_CHECK="~PM_RUNTIME"
+ ERROR_KERNEL_PM_RUNTIME="PM_RUNTIME should be enabled in the kernel for full powertop function"
+ check_extra_config
+ else
+ CONFIG_CHECK="~PM"
+ ERROR_KERNEL_PM="PM should be enabled in the kernel for full powertop function"
+ check_extra_config
+ fi
+ fi
+}
+
+src_configure() {
+ export ac_cv_search_delwin=$(usex unicode -lncursesw -lncurses)
+ econf $(use_enable nls)
+}