summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2017-02-09 20:06:03 -0500
committerMike Frysinger <vapier@gentoo.org>2017-02-09 20:48:44 -0500
commit9922424d24e74a94290fddeca93a861bae8ebedf (patch)
treee740bd2efe80cf0739e6c108ed8930a54d1881b7 /sys-process/audit
parentsys-process/audit: use prefix vars for base paths (diff)
downloadgentoo-9922424d24e74a94290fddeca93a861bae8ebedf.tar.gz
gentoo-9922424d24e74a94290fddeca93a861bae8ebedf.tar.bz2
gentoo-9922424d24e74a94290fddeca93a861bae8ebedf.zip
sys-process/audit: add USE=gssapi support #424653
Diffstat (limited to 'sys-process/audit')
-rw-r--r--sys-process/audit/audit-2.6.4.ebuild18
-rw-r--r--sys-process/audit/metadata.xml3
2 files changed, 13 insertions, 8 deletions
diff --git a/sys-process/audit/audit-2.6.4.ebuild b/sys-process/audit/audit-2.6.4.ebuild
index 0f4ddd8ceb54..a7d63c107d8f 100644
--- a/sys-process/audit/audit-2.6.4.ebuild
+++ b/sys-process/audit/audit-2.6.4.ebuild
@@ -15,18 +15,19 @@ SRC_URI="https://people.redhat.com/sgrubb/audit/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
-IUSE="ldap python"
+IUSE="gssapi ldap python"
# Testcases are pretty useless as they are built for RedHat users/groups and kernels.
RESTRICT="test"
-RDEPEND="ldap? ( net-nds/openldap )
- sys-libs/libcap-ng"
+RDEPEND="gssapi? ( virtual/krb5 )
+ ldap? ( net-nds/openldap )
+ sys-libs/libcap-ng"
DEPEND="${RDEPEND}
- >=sys-kernel/linux-headers-2.6.34
- python? (
- ${PYTHON_DEPS}
- dev-lang/swig:0
- )"
+ >=sys-kernel/linux-headers-2.6.34
+ python? (
+ ${PYTHON_DEPS}
+ dev-lang/swig:0
+ )"
# Do not use os-headers as this is linux specific
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -77,6 +78,7 @@ multilib_src_configure() {
local ECONF_SOURCE=${S}
econf \
--sbindir="${EPREFIX}/sbin" \
+ $(use_enable gssapi gssapi-krb5) \
--enable-systemd \
--without-python \
--without-python3
diff --git a/sys-process/audit/metadata.xml b/sys-process/audit/metadata.xml
index ee74e58c0375..856de3a78717 100644
--- a/sys-process/audit/metadata.xml
+++ b/sys-process/audit/metadata.xml
@@ -4,4 +4,7 @@
<maintainer type="person">
<email>robbat2@gentoo.org</email>
</maintainer>
+<use>
+ <flag name="gssapi">Enable GSSAPI support</flag>
+</use>
</pkgmetadata>