summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-process/criu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-process/criu')
-rw-r--r--sys-process/criu/Manifest2
-rw-r--r--sys-process/criu/criu-1.5.2.ebuild50
-rw-r--r--sys-process/criu/criu-1.6-r1.ebuild72
-rw-r--r--sys-process/criu/files/criu-1.3.1-flags.patch55
-rw-r--r--sys-process/criu/files/criu-1.3.1-makefile.patch20
-rw-r--r--sys-process/criu/files/criu-1.5-automagic-libbsd.patch29
-rw-r--r--sys-process/criu/files/criu-1.5.1-arm64-ptrace.patch12
-rw-r--r--sys-process/criu/metadata.xml12
8 files changed, 252 insertions, 0 deletions
diff --git a/sys-process/criu/Manifest b/sys-process/criu/Manifest
new file mode 100644
index 000000000000..d6611bb3118c
--- /dev/null
+++ b/sys-process/criu/Manifest
@@ -0,0 +1,2 @@
+DIST criu-1.5.2.tar.bz2 457573 SHA256 e8226018ac6c4094d61a1c002543e2b2253b4041a8edb24d4c1eaa41ce5ab345 SHA512 c7916fde1f63cb66a89e71867c204a251dfa2b9de703ac467bc460c6f0d895947996fd466c17cb529d2502aba7b75b8b30162baf3944fefebb71625fb88e5458 WHIRLPOOL c951692e684bd1b032bde1b534a4f4bd4b769a1e73afc56c74711ac943da907f638489205e8be2c68bbc345c1da8b641a7175dccd34aad907ca3251c3f2156a0
+DIST criu-1.6.tar.bz2 484513 SHA256 35ba6f5df90bfb8a25ae5e53459272bb37b8a69790e084f86d7a9ffa0df35993 SHA512 0672c7342ffed7c23fdb747b7bd3b08f205a4bf3965577991d007f71e70be5243247e52ad823f0099713f7977f6f4be5403ea2073a840b5024b6a0f240f65bdc WHIRLPOOL da5a767b3f89efdd2cda21331cc60e60e0cdbab163a55ef1a3080d3601df924688d612c7e76000c3d383cdb22002b16c28ad2740b7bc6aba784021f31ebc54c4
diff --git a/sys-process/criu/criu-1.5.2.ebuild b/sys-process/criu/criu-1.5.2.ebuild
new file mode 100644
index 000000000000..55dad0c137d5
--- /dev/null
+++ b/sys-process/criu/criu-1.5.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs linux-info flag-o-matic
+
+DESCRIPTION="utility to checkpoint/restore a process tree"
+HOMEPAGE="http://criu.org/"
+SRC_URI="http://download.openvz.org/criu/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="setproctitle"
+
+RDEPEND="dev-libs/protobuf-c
+ setproctitle? ( dev-libs/libbsd )"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ app-text/xmlto"
+
+CONFIG_CHECK="~CHECKPOINT_RESTORE ~NAMESPACES ~PID_NS ~FHANDLE ~EVENTFD ~EPOLL ~INOTIFY_USER
+ ~IA32_EMULATION ~UNIX_DIAG ~INET_DIAG ~INET_UDP_DIAG ~PACKET_DIAG ~NETLINK_DIAG"
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.3.1-flags.patch
+ epatch "${FILESDIR}"/${PN}-1.3.1-makefile.patch
+ epatch "${FILESDIR}"/${PN}-1.5-automagic-libbsd.patch
+}
+
+src_compile() {
+ unset ARCH
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" V=1 SETPROCTITLE=$(usex setproctitle) WERROR=0 all docs
+}
+
+src_test() {
+ # root privileges are required to dump all necessary info
+ if [[ ${EUID} -eq 0 ]] ; then
+ emake -j1 CC="$(tc-getCC)" V=1 WERROR=0 test
+ fi
+}
+
+src_install() {
+ emake SYSCONFDIR="${EPREFIX}"/etc PREFIX="${EPREFIX}"/usr DESTDIR="${D}" install
+ dodoc CREDITS README
+}
diff --git a/sys-process/criu/criu-1.6-r1.ebuild b/sys-process/criu/criu-1.6-r1.ebuild
new file mode 100644
index 000000000000..3806853b814e
--- /dev/null
+++ b/sys-process/criu/criu-1.6-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs linux-info flag-o-matic
+
+DESCRIPTION="utility to checkpoint/restore a process tree"
+HOMEPAGE="http://criu.org/"
+SRC_URI="http://download.openvz.org/criu/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="setproctitle"
+
+RDEPEND="dev-libs/protobuf-c
+ setproctitle? ( dev-libs/libbsd )"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ app-text/xmlto"
+
+CONFIG_CHECK="~CHECKPOINT_RESTORE ~NAMESPACES ~PID_NS ~FHANDLE ~EVENTFD ~EPOLL ~INOTIFY_USER
+ ~IA32_EMULATION ~UNIX_DIAG ~INET_DIAG ~INET_UDP_DIAG ~PACKET_DIAG ~NETLINK_DIAG"
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.3.1-flags.patch
+ epatch "${FILESDIR}"/${PN}-1.3.1-makefile.patch
+ epatch "${FILESDIR}"/${PN}-1.5-automagic-libbsd.patch
+}
+
+criu_arch() {
+ # criu infers the arch from $(uname -m). We never want this to happen.
+ case ${ARCH} in
+ amd64) echo "x86_64";;
+ arm64) echo "aarch64";;
+ x86) echo "i386";;
+ *) echo "${ARCH}";;
+ esac
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getLD)" \
+ OBJCOPY="$(tc-getOBJCOPY)" \
+ ARCH="$(criu_arch)" \
+ V=1 WERROR=0 \
+ SETPROCTITLE=$(usex setproctitle) \
+ all docs
+}
+
+src_test() {
+ # root privileges are required to dump all necessary info
+ if [[ ${EUID} -eq 0 ]] ; then
+ emake -j1 CC="$(tc-getCC)" ARCH="$(criu_arch)" V=1 WERROR=0 test
+ fi
+}
+
+src_install() {
+ emake \
+ ARCH="$(criu_arch)" \
+ PREFIX="${EPREFIX}"/usr \
+ LOGROTATEDIR="${EPREFIX}"/etc/logrotate.d \
+ DESTDIR="${D}" \
+ install
+
+ dodoc CREDITS README.md
+}
diff --git a/sys-process/criu/files/criu-1.3.1-flags.patch b/sys-process/criu/files/criu-1.3.1-flags.patch
new file mode 100644
index 000000000000..84f503770557
--- /dev/null
+++ b/sys-process/criu/files/criu-1.3.1-flags.patch
@@ -0,0 +1,55 @@
+--- criu-1.3.1/Makefile
++++ criu-1.3.1/Makefile
+@@ -102,9 +102,6 @@
+
+ ifeq ($(DEBUG),1)
+ DEFINES += -DCR_DEBUG
+- CFLAGS += -O0 -ggdb3
+-else
+- CFLAGS += -O2
+ endif
+
+ ifeq ($(GMON),1)
+--- criu-1.3.1/test/zdtm/lib/Makefile
++++ criu-1.3.1/test/zdtm/lib/Makefile
+@@ -1,6 +1,6 @@
+ include ../Makefile.inc
+
+-CFLAGS = -g -O2 -Wall -Werror -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0
++CFLAGS = -Wall -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0
+ CFLAGS += $(USERCFLAGS)
+
+ LIBDIR = .
+--- criu-1.3.1/test/zdtm/live/static/Makefile
++++ criu-1.3.1/test/zdtm/live/static/Makefile
+@@ -3,7 +3,7 @@
+ LIBDIR = ../../lib
+ LIB = $(LIBDIR)/libzdtmtst.a
+ override CPPFLAGS += -I$(LIBDIR)
+-CFLAGS = -g -O2 -Wall -Werror -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0
++CFLAGS = -Wall -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0
+ CFLAGS += $(USERCFLAGS)
+
+ TST_NOFILE = \
+--- criu-1.3.1/test/zdtm/live/streaming/Makefile
++++ criu-1.3.1/test/zdtm/live/streaming/Makefile
+@@ -3,7 +3,7 @@
+ LIBDIR = ../../lib
+ LIB = $(LIBDIR)/libzdtmtst.a
+ override CPPFLAGS += -I$(LIBDIR)
+-CFLAGS = -g -O2 -Wall -Werror -fno-strict-aliasing
++CFLAGS = -Wall -fno-strict-aliasing
+ CFLAGS += $(USERCFLAGS)
+
+ TST_NOFILE = \
+--- criu-1.3.1/test/zdtm/live/transition/Makefile
++++ criu-1.3.1/test/zdtm/live/transition/Makefile
+@@ -3,7 +3,7 @@
+ LIBDIR = ../../lib
+ LIB = $(LIBDIR)/libzdtmtst.a
+ override CPPFLAGS += -I$(LIBDIR)
+-CFLAGS = -g -O2 -Wall -Werror
++CFLAGS = -Wall
+ CFLAGS += $(USERCFLAGS)
+
+ TST_NOFILE = \
diff --git a/sys-process/criu/files/criu-1.3.1-makefile.patch b/sys-process/criu/files/criu-1.3.1-makefile.patch
new file mode 100644
index 000000000000..50781c192aa8
--- /dev/null
+++ b/sys-process/criu/files/criu-1.3.1-makefile.patch
@@ -0,0 +1,20 @@
+--- criu-1.3.1/Makefile.inc
++++ criu-1.3.1/Makefile.inc
+@@ -15,15 +15,9 @@
+ SBINDIR := $(PREFIX)/sbin
+ MANDIR := $(PREFIX)/share/man
+ SYSTEMDUNITDIR := $(PREFIX)/lib/systemd/system/
+-LOGROTATEDIR := $(PREFIX)/etc/logrotate.d/
++LOGROTATEDIR := $(SYSCONFDIR)/etc/logrotate.d/
+ LIBDIR := $(PREFIX)/lib
+-# For recent Debian/Ubuntu with multiarch support
+-DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture \
+- -qDEB_HOST_MULTIARCH 2>/dev/null)
+-ifneq "$(DEB_HOST_MULTIARCH)" ""
+-LIBDIR := $(PREFIX)/lib/$(DEB_HOST_MULTIARCH)
+-# For most other systems
+-else ifeq "$(shell uname -m)" "x86_64"
++ifeq "$(shell uname -m)" "x86_64"
+ LIBDIR := $(PREFIX)/lib64
+ endif
+
diff --git a/sys-process/criu/files/criu-1.5-automagic-libbsd.patch b/sys-process/criu/files/criu-1.5-automagic-libbsd.patch
new file mode 100644
index 000000000000..8f5e4b4e02d0
--- /dev/null
+++ b/sys-process/criu/files/criu-1.5-automagic-libbsd.patch
@@ -0,0 +1,29 @@
+Control libbsd dependency via SETPROCTITLE definition.
+
+--- criu-1.5/Makefile.config
++++ criu-1.5/Makefile.config
+@@ -3,10 +3,12 @@
+
+ CONFIG := include/config.h
+
++ifeq ($(SETPROCTITLE),yes)
+ ifeq ($(call try-cc,$(LIBBSD_DEV_TEST),-lbsd),y)
+ LIBS += -lbsd
+ DEFINES += -DCONFIG_HAS_LIBBSD
+ endif
++endif
+
+ $(CONFIG): scripts/utilities.mak scripts/feature-tests.mak include/config-base.h
+ $(E) " GEN " $@
+@@ -33,9 +35,11 @@
+ ifeq ($(VDSO),y)
+ $(Q) @echo '#define CONFIG_VDSO' >> $@
+ endif
++ifeq ($(SETPROCTITLE),yes)
+ ifeq ($(call try-cc,$(SETPROCTITLE_INIT_TEST),-lbsd),y)
+ $(Q) @echo '#define CONFIG_HAS_SETPROCTITLE_INIT' >> $@
+ endif
++endif
+ $(Q) @echo '#endif /* __CR_CONFIG_H__ */' >> $@
+
+ config: $(CONFIG)
diff --git a/sys-process/criu/files/criu-1.5.1-arm64-ptrace.patch b/sys-process/criu/files/criu-1.5.1-arm64-ptrace.patch
new file mode 100644
index 000000000000..497838132a24
--- /dev/null
+++ b/sys-process/criu/files/criu-1.5.1-arm64-ptrace.patch
@@ -0,0 +1,12 @@
+diff --git a/arch/aarch64/include/asm/types.h b/arch/aarch64/include/asm/types.h
+index 8dd336e..6657279 100644
+--- a/arch/aarch64/include/asm/types.h
++++ b/arch/aarch64/include/asm/types.h
+@@ -3,6 +3,7 @@
+
+ #include <stdbool.h>
+ #include <signal.h>
++#include <asm/ptrace.h>
+ #include "protobuf/core.pb-c.h"
+
+ #include "asm-generic/page.h"
diff --git a/sys-process/criu/metadata.xml b/sys-process/criu/metadata.xml
new file mode 100644
index 000000000000..4ff189ce3f9a
--- /dev/null
+++ b/sys-process/criu/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version = '1.0' encoding = 'UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>virtualization</herd>
+ <maintainer>
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+ <use>
+ <flag name='setproctitle'>Make process titles of service workers to be more verbose</flag>
+ </use>
+</pkgmetadata>