summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-07-22 10:48:55 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-07-22 10:53:01 +0200
commitc141b6b91c7c21b326e77d00768798343bce3275 (patch)
tree351fa74c5abec31cbd8cf482da5f85aa319fe418 /sys-process/htop/htop-2.0.2.ebuild
parentmedia-libs/xine-lib: Removed old. (diff)
downloadgentoo-c141b6b91c7c21b326e77d00768798343bce3275.tar.gz
gentoo-c141b6b91c7c21b326e77d00768798343bce3275.tar.bz2
gentoo-c141b6b91c7c21b326e77d00768798343bce3275.zip
sys-process/htop: Bump to version 2.0.2
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-process/htop/htop-2.0.2.ebuild')
-rw-r--r--sys-process/htop/htop-2.0.2.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sys-process/htop/htop-2.0.2.ebuild b/sys-process/htop/htop-2.0.2.ebuild
new file mode 100644
index 000000000000..a64dffefa64b
--- /dev/null
+++ b/sys-process/htop/htop-2.0.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools linux-info
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://hisham.hm/htop/"
+SRC_URI="http://hisham.hm/htop/releases/${PV}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="kernel_FreeBSD kernel_linux openvz unicode vserver"
+
+RDEPEND="sys-libs/ncurses:0=[unicode?]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( ChangeLog README )
+
+CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.2-tinfo.patch"
+)
+
+pkg_setup() {
+ if ! has_version sys-process/lsof; then
+ ewarn "To use lsof features in htop(what processes are accessing"
+ ewarn "what files), you must have sys-process/lsof installed."
+ fi
+
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ rm missing || die
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ [[ $CBUILD != $CHOST ]] && export ac_cv_file__proc_{meminfo,stat}=yes #328971
+
+ local myeconfargs=()
+
+ myeconfargs+=(
+ # fails to build against recent hwloc versions
+ --disable-hwloc
+ --enable-taskstats
+ $(use_enable kernel_linux cgroup)
+ $(use_enable kernel_linux linux-affinity)
+ $(use_enable openvz)
+ $(use_enable unicode)
+ $(use_enable vserver)
+ )
+ econf ${myeconfargs[@]}
+}