summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-08-16 20:07:10 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-08-16 20:07:10 +0200
commit2f9fb28b63f2b3102817e8c4444ace952bdc7ecb (patch)
tree979e17074843b74baa8ac9446a712c94fc2eaaaf /sys-process/memwatch/memwatch-0.3.2.ebuild
parentdev-java/cssparser: version bump. (diff)
downloadgentoo-2f9fb28b63f2b3102817e8c4444ace952bdc7ecb.tar.gz
gentoo-2f9fb28b63f2b3102817e8c4444ace952bdc7ecb.tar.bz2
gentoo-2f9fb28b63f2b3102817e8c4444ace952bdc7ecb.zip
sys-process/memwatch: version bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-process/memwatch/memwatch-0.3.2.ebuild')
-rw-r--r--sys-process/memwatch/memwatch-0.3.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-process/memwatch/memwatch-0.3.2.ebuild b/sys-process/memwatch/memwatch-0.3.2.ebuild
new file mode 100644
index 000000000000..804b28eaef3d
--- /dev/null
+++ b/sys-process/memwatch/memwatch-0.3.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Interactive memory viewer"
+HOMEPAGE="https://unixdev.ru/memwatch"
+SRC_URI="http://unixdev.ru/src/${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+CMAKE_REMOVE_MODULES_LIST="FindCurses"
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}