summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Chren <dev.rindeal@gmail.com>2016-06-21 22:44:31 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-06-26 09:37:41 +0000
commit29ca13b081452e8a85873e12b7af21d4bf381c9d (patch)
tree092060399310870f2fab65606e1148919ad7a852 /sys-process/nmon/nmon-16f.ebuild
parentdev-ml/enumerate: Fix || operator error and depend on dev-ml/camlp4 only inst... (diff)
downloadgentoo-29ca13b081452e8a85873e12b7af21d4bf381c9d.tar.gz
gentoo-29ca13b081452e8a85873e12b7af21d4bf381c9d.tar.bz2
gentoo-29ca13b081452e8a85873e12b7af21d4bf381c9d.zip
sys-process/nmon: bump to v16f
Closes: https://github.com/gentoo/gentoo/pull/1713 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'sys-process/nmon/nmon-16f.ebuild')
-rw-r--r--sys-process/nmon/nmon-16f.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-process/nmon/nmon-16f.ebuild b/sys-process/nmon/nmon-16f.ebuild
new file mode 100644
index 000000000000..30889383c554
--- /dev/null
+++ b/sys-process/nmon/nmon-16f.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+MY_P="lmon${PV}"
+
+DESCRIPTION="Nigel's performance MONitor for CPU, memory, network, disks, etc..."
+HOMEPAGE="http://nmon.sourceforge.net/"
+LICENSE="GPL-3"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.c"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm ~ppc64"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp -v -f "${DISTDIR}"/${MY_P}.c "${S}"/${PN}.c || die
+}
+
+src_configure() {
+ local cflags=(
+ ## recommended by upstream to be always on
+ -DGETUSER
+ -DJFS
+ -DLARGEMEM
+ -DKERNEL_2_6_18
+
+ ## archs
+ $(usex amd64 -DX86 '')
+ $(usex x86 -DX86 '')
+ $(usex arm -DARM '')
+ $(usex ppc64 -DPOWER '')
+ )
+ append-cflags "${cflags[@]}"
+ export LDLIBS="$( $(tc-getPKG_CONFIG) --libs ncurses ) -lm"
+}
+
+src_compile() {
+ emake ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+}