summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-06-19 00:26:07 -0400
committerTim Harder <radhermit@gentoo.org>2016-06-19 00:26:07 -0400
commit1f65aba00da5718fb249c97ed2d0022148479efe (patch)
treebce6e047339becf617fc594a918040de0620027d /sys-process/procenv/procenv-0.46.ebuild
parentdev-lang/swig: remove old (diff)
downloadgentoo-1f65aba00da5718fb249c97ed2d0022148479efe.tar.gz
gentoo-1f65aba00da5718fb249c97ed2d0022148479efe.tar.bz2
gentoo-1f65aba00da5718fb249c97ed2d0022148479efe.zip
sys-process/procenv: version bump to 0.46
Diffstat (limited to 'sys-process/procenv/procenv-0.46.ebuild')
-rw-r--r--sys-process/procenv/procenv-0.46.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-process/procenv/procenv-0.46.ebuild b/sys-process/procenv/procenv-0.46.ebuild
new file mode 100644
index 000000000000..fea114e4335f
--- /dev/null
+++ b/sys-process/procenv/procenv-0.46.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="command-line utility to show process environment"
+HOMEPAGE="https://github.com/jamesodhunt/procenv"
+SRC_URI="https://github.com/jamesodhunt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND="
+ virtual/pkgconfig
+ test? ( dev-libs/check )
+"
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-0.45-sysmacros.patch
+ "${FILESDIR}"/${PN}-0.45-flags.patch
+ )
+
+ default
+ eautoreconf
+}