summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-06-17 10:49:46 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-06-17 10:50:01 +0200
commit2c21e09a8d681418a39c5333481ab223e9c6d6e0 (patch)
treefa252b44aa4b9a5f759e775bb2df16dea47ed13f /sys-process/psmisc/psmisc-23.1.ebuild
parentapp-admin/geolizer: Remove last-rited pkg, #514850 (diff)
downloadgentoo-2c21e09a8d681418a39c5333481ab223e9c6d6e0.tar.gz
gentoo-2c21e09a8d681418a39c5333481ab223e9c6d6e0.tar.bz2
gentoo-2c21e09a8d681418a39c5333481ab223e9c6d6e0.zip
sys-process/psmisc: Bump to version 23.1
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sys-process/psmisc/psmisc-23.1.ebuild')
-rw-r--r--sys-process/psmisc/psmisc-23.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-process/psmisc/psmisc-23.1.ebuild b/sys-process/psmisc/psmisc-23.1.ebuild
new file mode 100644
index 000000000000..e25d09501c93
--- /dev/null
+++ b/sys-process/psmisc/psmisc-23.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A set of tools that use the proc filesystem"
+HOMEPAGE="http://psmisc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="ipv6 nls selinux X"
+
+RDEPEND=">=sys-libs/ncurses-5.7-r7:0=
+ nls? ( virtual/libintl )
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2.6b
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable selinux)
+ --disable-harden-flags
+ $(use_enable ipv6)
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # peekfd is a fragile crap hack #330631
+ nonfatal emake -C src peekfd || touch src/peekfd{.o,}
+ emake
+}
+
+src_install() {
+ default
+
+ use X || rm -f "${ED}"/usr/bin/pstree.x11
+
+ [[ -s ${ED}/usr/bin/peekfd ]] || rm -f "${ED}"/usr/bin/peekfd
+ [[ -e ${ED}/usr/bin/peekfd ]] || rm -f "${ED}"/usr/share/man/man1/peekfd.1
+
+ # fuser is needed by init.d scripts; use * wildcard for #458250
+ dodir /bin
+ mv "${ED}"/usr/bin/*fuser "${ED}"/bin || die
+}