summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-11-03 11:15:29 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-11-03 11:23:13 +0200
commitbe1e3a43d0c24b8a839eb947ecf2cce780e09c4a (patch)
tree2e9a5002a72fb214ea798fd73a638ceef54d47b8 /sys-process/uksmd
parentdev-python/libpillowfight: add 0.3.0_p20210816, enable tests (diff)
downloadgentoo-be1e3a43d0c24b8a839eb947ecf2cce780e09c4a.tar.gz
gentoo-be1e3a43d0c24b8a839eb947ecf2cce780e09c4a.tar.bz2
gentoo-be1e3a43d0c24b8a839eb947ecf2cce780e09c4a.zip
sys-process/uksmd: add 2021-10-19 snapshot
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-process/uksmd')
-rw-r--r--sys-process/uksmd/Manifest1
-rw-r--r--sys-process/uksmd/uksmd-0_pre20211019.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-process/uksmd/Manifest b/sys-process/uksmd/Manifest
index 5efd5ef4a69c..3c2d9cfd5231 100644
--- a/sys-process/uksmd/Manifest
+++ b/sys-process/uksmd/Manifest
@@ -1 +1,2 @@
DIST uksmd-0_pre20200505.tar.bz2 14038 BLAKE2B a87ebd14dd8efd51476af8e8c2d3d6b31290bee3b29bac85a2ca2478a27d7128e82db36de8b055ec1aef2825552131291aa17d1927aee9cefbd05ffd78aac710 SHA512 0a0e41beeadeb9c42dac36be8f9fa25956226961b4d16725f03277bf4cf87f42e984a83af0787eb621d9c35277906df309899a741bb94b134fa3d21b6852ac50
+DIST uksmd-0_pre20211019.tar.bz2 14434 BLAKE2B de17d4dd566eec378062d2040b9387ddbe88f14c9d0ac121d7357d9da190fb5426476b59158655104af4de2be49d14367fe13328de2fb40df23cceddbf6f1a3e SHA512 89f3784c50e1a9bae28e12f562d1c28f97b71859d3b0e2d83416785f9c47cd7da2b93481855c4b46ae6c71c332534991c28b98a5497b301c1d674744308681ce
diff --git a/sys-process/uksmd/uksmd-0_pre20211019.ebuild b/sys-process/uksmd/uksmd-0_pre20211019.ebuild
new file mode 100644
index 000000000000..bbc2fd9e6bf8
--- /dev/null
+++ b/sys-process/uksmd/uksmd-0_pre20211019.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+MY_COMMIT="e1d4b12d22fd710f0155d75585940f0d439f1544"
+MY_P="${PN}-${MY_COMMIT}"
+
+DESCRIPTION="Userspace KSM helper daemon"
+HOMEPAGE="https://gitlab.com/post-factum/uksmd"
+SRC_URI="https://gitlab.com/post-factum/uksmd/-/archive/${MY_COMMIT}/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/libcap-ng
+ sys-process/procps:="
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~KSM"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/uksmd-0_pre20200504-respect-cflags-ldflags.patch" )
+
+src_install() {
+ default
+ einstalldocs
+
+ newinitd "${FILESDIR}/uksmd.init" uksmd
+ systemd_dounit distro/uksmd.service
+}