summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-08-24 03:55:14 +0000
committerZero_Chaos <zerochaos@gentoo.org>2018-08-24 03:55:28 +0000
commit5092d2c6d710c654fc271dd434e260f034597d50 (patch)
treeb60cc31dfc9c549397bb7b367d8c2d14c404d817 /sys-process/usbtop
parentx11-libs/libX11: mark s390 stable (diff)
downloadgentoo-5092d2c6d710c654fc271dd434e260f034597d50.tar.gz
gentoo-5092d2c6d710c654fc271dd434e260f034597d50.tar.bz2
gentoo-5092d2c6d710c654fc271dd434e260f034597d50.zip
sys-process/usbtop: initial commit
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'sys-process/usbtop')
-rw-r--r--sys-process/usbtop/Manifest1
-rw-r--r--sys-process/usbtop/metadata.xml10
-rw-r--r--sys-process/usbtop/usbtop-0.2.ebuild29
3 files changed, 40 insertions, 0 deletions
diff --git a/sys-process/usbtop/Manifest b/sys-process/usbtop/Manifest
new file mode 100644
index 000000000000..0eac4db7eb22
--- /dev/null
+++ b/sys-process/usbtop/Manifest
@@ -0,0 +1 @@
+DIST usbtop-0.2.tar.gz 10828 BLAKE2B d595fda23adee6778060c25176d1951250bb45cc25ea8040661222736c63aa356605ec8ca52b71e7142cf0f8e7807a77a54fffbc54165178f44af63dfb5ba712 SHA512 43a4512abcff6107ac7a56d65ee19c2b17f4aeb9d38e42e630d724c6744c7d23c85d2c66325c0e6b50404431312754646f1290202fa51f3dee1f94a9d211ba25
diff --git a/sys-process/usbtop/metadata.xml b/sys-process/usbtop/metadata.xml
new file mode 100644
index 000000000000..f513208bf390
--- /dev/null
+++ b/sys-process/usbtop/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-process/usbtop/usbtop-0.2.ebuild b/sys-process/usbtop/usbtop-0.2.ebuild
new file mode 100644
index 000000000000..2661c02577d9
--- /dev/null
+++ b/sys-process/usbtop/usbtop-0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils linux-info
+
+DESCRIPTION="utility that shows an estimated instantaneous bandwidth on USB buses and devices"
+HOMEPAGE="https://github.com/aguinet/usbtop"
+SRC_URI="https://github.com/aguinet/usbtop/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-libs/libpcap:=[usb]
+ dev-libs/boost:=[threads]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ if linux_config_exists; then
+ CONFIG_CHECK="~USB_MON"
+ check_extra_config
+ fi
+}