summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-08-10 03:39:36 -0400
committerMike Frysinger <vapier@gentoo.org>2015-08-10 03:59:50 -0400
commit2f168392284fec294f9bfbb06d1c0a8a46f5a7d5 (patch)
treec358f3923e0d894231454ec7fe5a978a48664415 /sys-process
parentanacron: install with normal permissions #291565 (diff)
downloadgentoo-2f168392284fec294f9bfbb06d1c0a8a46f5a7d5.tar.gz
gentoo-2f168392284fec294f9bfbb06d1c0a8a46f5a7d5.tar.bz2
gentoo-2f168392284fec294f9bfbb06d1c0a8a46f5a7d5.zip
anacron: improve CFLAGS/CC handling
Rather than expand CFLAGS in the sed statement, pass it via the env later on when running make. Make sure we set up CC to a sane default.
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/anacron/anacron-2.3-r3.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys-process/anacron/anacron-2.3-r3.ebuild b/sys-process/anacron/anacron-2.3-r3.ebuild
index aa35863c8a09..202cfdd6b889 100644
--- a/sys-process/anacron/anacron-2.3-r3.ebuild
+++ b/sys-process/anacron/anacron-2.3-r3.ebuild
@@ -4,7 +4,7 @@
EAPI="5"
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="a periodic command scheduler"
HOMEPAGE="http://anacron.sourceforge.net/"
@@ -21,7 +21,13 @@ RDEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-compile-fix-from-debian.patch
- sed -i "s:^CFLAGS =:CFLAGS = $CFLAGS:" Makefile
+ sed -i \
+ -e '/^CFLAGS/{s:=:+=:;s:-O2::}' \
+ Makefile || die
+}
+
+src_configure() {
+ tc-export CC
}
src_install() {