summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-09-16 18:30:46 +0200
committerUlrich Müller <ulm@gentoo.org>2023-11-19 11:12:13 +0100
commit416499d220e951fd6ee2e8a88074be2ba240244b (patch)
tree5ea3858ac9e98da55bf485866e576330e837ad9f /sys-process
parentsys-apps/duc: version bump (v1.4.5) (diff)
downloadgentoo-416499d220e951fd6ee2e8a88074be2ba240244b.tar.gz
gentoo-416499d220e951fd6ee2e8a88074be2ba240244b.tar.bz2
gentoo-416499d220e951fd6ee2e8a88074be2ba240244b.zip
sys-process/cronutils: EAPI8 bump, version bump (v1.10)
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/cronutils/Manifest1
-rw-r--r--sys-process/cronutils/cronutils-1.10.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/sys-process/cronutils/Manifest b/sys-process/cronutils/Manifest
index 323a9ed2e5ca..343deb2400bf 100644
--- a/sys-process/cronutils/Manifest
+++ b/sys-process/cronutils/Manifest
@@ -1 +1,2 @@
+DIST cronutils-1.10.tar.gz 17098 BLAKE2B e450d9547355a6e6c447c533c69837b0e4a0c7f2100d1afe4088951ff988dea38029d3aac7433360ef3952d8ad9b1c0d90d6443546f7730e5bdd001612ed1ca7 SHA512 15f42054d86d7352d1454b3a18d959db3dc73d207fa3304708c002bfbcc86e630e97306ec84a26a904deb080428f5cc8c046aea55adbea2e69de2b4fab7538f4
DIST cronutils-1.9.tar.gz 15997 BLAKE2B 8fbd364dd50db8dc66febbd59eda17437865396fe419e9c967f7a57ea8a8782239b8acc6381fd1a7c5a15b8e5ab308bfc4869f4e696cc9a7221ddacc6786aa59 SHA512 ac9ff2c39090f851a3a581aea7f88bdf9b0eaac54c10f401fb2a54a8970f2103a76ac584e852813b09e75214c7c39d6489c5cd28a151e2c063f3dcb9d6db62b6
diff --git a/sys-process/cronutils/cronutils-1.10.ebuild b/sys-process/cronutils/cronutils-1.10.ebuild
new file mode 100644
index 000000000000..d15e4328cafb
--- /dev/null
+++ b/sys-process/cronutils/cronutils-1.10.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utilities to assist running batch processing jobs"
+HOMEPAGE="https://github.com/google/cronutils"
+SRC_URI="https://github.com/google/${PN}/archive/version/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-version-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="-D_XOPEN_SOURCE=500 ${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install
+}