summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-02 22:54:43 +0100
committerSam James <sam@gentoo.org>2022-07-02 22:58:16 +0100
commit4c95c5da862f62be2550f741e21f5fc4faaa7567 (patch)
tree03c12f0fcb680246b2129e936bca38469ca2dd3f /sys-process
parentsys-process/parallel: drop 20220322 (diff)
downloadgentoo-4c95c5da862f62be2550f741e21f5fc4faaa7567.tar.gz
gentoo-4c95c5da862f62be2550f741e21f5fc4faaa7567.tar.bz2
gentoo-4c95c5da862f62be2550f741e21f5fc4faaa7567.zip
sys-process/parallel: add 20220622
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/parallel/Manifest2
-rw-r--r--sys-process/parallel/files/parallel-20220622-makefile-completions.patch23
-rw-r--r--sys-process/parallel/parallel-20220622.ebuild40
3 files changed, 65 insertions, 0 deletions
diff --git a/sys-process/parallel/Manifest b/sys-process/parallel/Manifest
index 71c9f796563d..60bd33ecf10d 100644
--- a/sys-process/parallel/Manifest
+++ b/sys-process/parallel/Manifest
@@ -2,3 +2,5 @@ DIST parallel-20220422.tar.bz2 2367837 BLAKE2B 5630c58a15cc6ce0dac0346188afa9916
DIST parallel-20220422.tar.bz2.sig 2080 BLAKE2B ae87bf4bee2cdd6952e30bb2b65498ca3f4d51452ff8736ac4c8cfbc9bf940eebad48c0c08d474d02d269eb459cb62441067b0c6f6ad69f8beedad40710637a3 SHA512 a8d023d856722fb7528fa67ff1615643e9bf3036c903665ca94e5c7366b402b1bc1b25defd4d3c9dbacc5178a9c584249639e45d3713c991c21da01158fa85da
DIST parallel-20220522.tar.bz2 2372671 BLAKE2B e32f62930a4147dc950f5bdab1da58bef19c83b75e7257511d44257ef1569b40a34c670c63831f46daabcb390a197b7293aabb66f2dacd9848dd64910fd3b912 SHA512 45dd1abe8652d29cd054505263b4ed792f42d7d6799ebdbfec07c21d54437d7243a054adff1d6c987eb85260d7ead2a9bb4dacb9d54a8a5b332218e27cf4f62c
DIST parallel-20220522.tar.bz2.sig 2080 BLAKE2B 52d49780713d113344232c572f325109f35df966f3f9840ed7522b9414e7860bd8117f42e1ef1d5be22471e455f6f189766bcc40e3d2afb689bfda64de08ade8 SHA512 6b3cd5f93bc3db979fa0ae70a565ccea2a2dc37fc534b76fb8660092ec63244e550470782e477d815d619c540237afb7e124316a5e89d6ddeaf89689c1810ee5
+DIST parallel-20220622.tar.bz2 2378286 BLAKE2B a0fdb1ab330360c28d85ea5608760a961e663a5401b900e6e8eee944250bf233ae1e3f66e6a2b9d54f0c32702127593dab787d29eda636bd457dcc5d4b046785 SHA512 d01d86cd2ac373534d147eee8aa666fe26e7207362ea9c036c3744125f72c936d15cf2059429636454f21c8e8c6b3a60c8d761ddfde97ba7388d2cd00495bfa4
+DIST parallel-20220622.tar.bz2.sig 2080 BLAKE2B f013d329dd3e6d46341638965582ef5eb7358b8dff5e858279808a38d8543dd900fcc248433e30a3a715e1726be10dad5597deec23519bb33a904006f72a92d8 SHA512 097ca0f3ca9afe96045738fe050f94ba588e7728ae7cbf4f695b7f1f6c148ccc1565839aec2ba3ce4ccaf888331365b9b7265aa434806ef2c76139e2ba2f0e82
diff --git a/sys-process/parallel/files/parallel-20220622-makefile-completions.patch b/sys-process/parallel/files/parallel-20220622-makefile-completions.patch
new file mode 100644
index 000000000000..24b479a33a2a
--- /dev/null
+++ b/sys-process/parallel/files/parallel-20220622-makefile-completions.patch
@@ -0,0 +1,23 @@
+https://lists.gnu.org/archive/html/parallel/2022-06/msg00010.html
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -170,12 +170,12 @@ pack_unpack_and_test_build:
+ zshcompletiondir=${datarootdir}/zsh/site-functions
+ zshcompletion=${zshcompletiondir}/_parallel
+ install-data-hook:
+- mkdir -p ${datarootdir}/bash-completion/completions
+- mkdir -p ${zshcompletiondir}
+- parallel --shell-completion bash > ${datarootdir}/bash-completion/completions/parallel
+- echo '#compdef parallel' > ${zshcompletion}
+- echo '(( $$+functions[_comp_parallel] )) ||' >> ${zshcompletion}
+- echo ' eval "$$(parallel --shell-completion auto)" &&' >> ${zshcompletion}
+- echo ' _comp_parallel' >> ${zshcompletion}
++ mkdir -p $(DESTDIR)${datarootdir}/bash-completion/completions
++ mkdir -p $(DESTDIR)${zshcompletiondir}
++ parallel --shell-completion bash > $(DESTDIR)${datarootdir}/bash-completion/completions/parallel
++ echo '#compdef parallel' > $(DESTDIR)${zshcompletion}
++ echo '(( $$+functions[_comp_parallel] )) ||' >> $(DESTDIR)${zshcompletion}
++ echo ' eval "$$(parallel --shell-completion auto)" &&' >> $(DESTDIR)${zshcompletion}
++ echo ' _comp_parallel' >> $(DESTDIR)${zshcompletion}
+
+ EXTRA_DIST = CITATION CITATION.cff CREDITS LICENSES/CC-BY-SA-4.0.txt LICENSES/GFDL-1.3-or-later.txt LICENSES/GPL-3.0-or-later.txt
diff --git a/sys-process/parallel/parallel-20220622.ebuild b/sys-process/parallel/parallel-20220622.ebuild
new file mode 100644
index 000000000000..f286660fe2f8
--- /dev/null
+++ b/sys-process/parallel/parallel-20220622.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/oletange.asc
+inherit autotools verify-sig
+
+DESCRIPTION="A shell tool for executing jobs in parallel locally or on remote machines"
+HOMEPAGE="https://www.gnu.org/software/parallel/ https://git.savannah.gnu.org/cgit/parallel.git/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+SRC_URI+=" verify-sig? ( mirror://gnu/${PN}/${P}.tar.bz2.sig )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="dev-lang/perl:=
+ dev-perl/Devel-Size
+ dev-perl/Text-CSV
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-IO"
+DEPEND="${RDEPEND}"
+BDEPEND="verify-sig? ( >=sec-keys/openpgp-keys-oletange-20210423 )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20220622-makefile-completions.patch
+)
+
+src_prepare() {
+ default
+
+ # Only for Makefile/completions patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+}