summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-02-05 17:53:01 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-02-05 17:53:22 -0500
commit542ea24d025c589074ca91c1d71c75a93f9b278e (patch)
treefa8772847a9fb196d1089888a995968aba2e079e /sys-process
parentdev-libs/libebml: stable 1.3.5 for ia64, bug #641292 (diff)
downloadgentoo-542ea24d025c589074ca91c1d71c75a93f9b278e.tar.gz
gentoo-542ea24d025c589074ca91c1d71c75a93f9b278e.tar.bz2
gentoo-542ea24d025c589074ca91c1d71c75a93f9b278e.zip
sys-process/fcron: make check_system_crontabs musl friendly
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/fcron/fcron-3.2.1-r3.ebuild (renamed from sys-process/fcron/fcron-3.2.1-r2.ebuild)3
-rw-r--r--sys-process/fcron/fcron-3.3.0_beta-r1.ebuild3
-rw-r--r--sys-process/fcron/files/fcron-3.2.1-musl-getopt-order.patch24
3 files changed, 28 insertions, 2 deletions
diff --git a/sys-process/fcron/fcron-3.2.1-r2.ebuild b/sys-process/fcron/fcron-3.2.1-r3.ebuild
index 604e9afb710b..fe5f30de4ec0 100644
--- a/sys-process/fcron/fcron-3.2.1-r2.ebuild
+++ b/sys-process/fcron/fcron-3.2.1-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -28,6 +28,7 @@ RDEPEND="${DEPEND}
PATCHES=(
"${FILESDIR}"/${PN}-3.1.1-noreadline.patch
"${FILESDIR}"/${PN}-3.2.1-configure-fix-audit-parameter-check.patch
+ "${FILESDIR}"/${PN}-3.2.1-musl-getopt-order.patch
)
pkg_setup() {
diff --git a/sys-process/fcron/fcron-3.3.0_beta-r1.ebuild b/sys-process/fcron/fcron-3.3.0_beta-r1.ebuild
index 10f03c92f516..f842946849e1 100644
--- a/sys-process/fcron/fcron-3.3.0_beta-r1.ebuild
+++ b/sys-process/fcron/fcron-3.3.0_beta-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -31,6 +31,7 @@ RDEPEND="${DEPEND}
PATCHES=(
"${FILESDIR}"/${PN}-3.1.1-noreadline.patch
"${FILESDIR}"/${PN}-3.2.1-configure-fix-audit-parameter-check.patch
+ "${FILESDIR}"/${PN}-3.2.1-musl-getopt-order.patch
)
S="${WORKDIR}/${MY_P}"
diff --git a/sys-process/fcron/files/fcron-3.2.1-musl-getopt-order.patch b/sys-process/fcron/files/fcron-3.2.1-musl-getopt-order.patch
new file mode 100644
index 000000000000..801baad91710
--- /dev/null
+++ b/sys-process/fcron/files/fcron-3.2.1-musl-getopt-order.patch
@@ -0,0 +1,24 @@
+diff -Naur fcron-3.2.1.orig/script/check_system_crontabs.bash fcron-3.2.1/script/check_system_crontabs.bash
+--- fcron-3.2.1.orig/script/check_system_crontabs.bash 2015-03-28 04:45:42.000000000 -0400
++++ fcron-3.2.1/script/check_system_crontabs.bash 2018-02-05 17:47:04.735425134 -0500
+@@ -256,7 +256,7 @@
+ sed -i -e "s/@yearly/0 0 1 1 */g" -e "s/@annually/0 0 1 1 */g" -e "s/@monthly/0 0 1 * */g" -e "s/@weekly/0 0 * * 0/g" -e "s/@daily/0 0 * * */g" -e "s/@midnight/0 0 * * */g" -e "s/@hourly/0 * * * */g" $FCRONTAB_FILE_TMP
+
+ # notify fcron about the updated file
+- $FCRONTAB_PROG $FCRONTAB_FILE_TMP -u systab
++ $FCRONTAB_PROG -u systab $FCRONTAB_FILE_TMP
+ }
+
+ NEED_REBUILD=0
+diff -Naur fcron-3.2.1.orig/script/check_system_crontabs.sh fcron-3.2.1/script/check_system_crontabs.sh
+--- fcron-3.2.1.orig/script/check_system_crontabs.sh 2015-03-28 04:45:42.000000000 -0400
++++ fcron-3.2.1/script/check_system_crontabs.sh 2018-02-05 17:45:48.673612299 -0500
+@@ -265,7 +265,7 @@
+ sed -i -e "s/@yearly/0 0 1 1 */g" -e "s/@annually/0 0 1 1 */g" -e "s/@monthly/0 0 1 * */g" -e "s/@weekly/0 0 * * 0/g" -e "s/@daily/0 0 * * */g" -e "s/@midnight/0 0 * * */g" -e "s/@hourly/0 * * * */g" "$FCRONTAB_FILE_TMP"
+
+ # notify fcron about the updated file
+- "$FCRONTAB_PROG" -c "$FCRON_CONFIG_FILE" "$FCRONTAB_FILE_TMP" -u systab
++ "$FCRONTAB_PROG" -c "$FCRON_CONFIG_FILE" -u systab "$FCRONTAB_FILE_TMP"
+ }
+
+ NEED_REBUILD=0