summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-04-16 16:59:58 -0400
committerTim Harder <radhermit@gentoo.org>2016-04-16 17:01:05 -0400
commit6b03f08744ea3c3c087c571e649d1f50ffdbbd1b (patch)
tree47bca38fc93056d7b4e54cec01db68c65b36f2ce /sys-process
parentsys-apps/systemd: Backport sysmacros fix (diff)
downloadgentoo-6b03f08744ea3c3c087c571e649d1f50ffdbbd1b.tar.gz
gentoo-6b03f08744ea3c3c087c571e649d1f50ffdbbd1b.tar.bz2
gentoo-6b03f08744ea3c3c087c571e649d1f50ffdbbd1b.zip
sys-process/procenv: explicitly include sysmacros header
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/procenv/files/procenv-0.45-sysmacros.patch23
-rw-r--r--sys-process/procenv/procenv-0.45.ebuild6
2 files changed, 29 insertions, 0 deletions
diff --git a/sys-process/procenv/files/procenv-0.45-sysmacros.patch b/sys-process/procenv/files/procenv-0.45-sysmacros.patch
new file mode 100644
index 000000000000..5d7230c4bc4d
--- /dev/null
+++ b/sys-process/procenv/files/procenv-0.45-sysmacros.patch
@@ -0,0 +1,23 @@
+Since glibc is moving away from implicitly including sys/sysmacros.h all the
+time via sys/types.h, include the header directly in more places.
+
+--- procenv-0.45/src/procenv.h
++++ procenv-0.45/src/procenv.h
+@@ -59,6 +59,7 @@
+ #include <getopt.h>
+ #include <assert.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <inttypes.h>
+ #include <sys/ioctl.h>
+ #include <sys/stat.h>
+--- procenv-0.45/src/util.h
++++ procenv-0.45/src/util.h
+@@ -22,6 +22,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <errno.h>
+ #include <stdbool.h>
+ #include <fcntl.h>
diff --git a/sys-process/procenv/procenv-0.45.ebuild b/sys-process/procenv/procenv-0.45.ebuild
index 32466f277aa8..3daf7544f795 100644
--- a/sys-process/procenv/procenv-0.45.ebuild
+++ b/sys-process/procenv/procenv-0.45.ebuild
@@ -4,6 +4,8 @@
EAPI=5
+inherit eutils
+
DESCRIPTION="command-line utility to show process environment"
HOMEPAGE="https://github.com/jamesodhunt/procenv"
SRC_URI="https://github.com/jamesodhunt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
@@ -17,3 +19,7 @@ DEPEND="
virtual/pkgconfig
test? ( dev-libs/check )
"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-sysmacros.patch
+}