summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2022-05-02 09:04:01 +0200
committerLars Wendler <polynomial-c@gentoo.org>2022-05-02 09:07:03 +0200
commit8e81a3a72fa3c6dc0043bbb3cdbd54ed66f13bbe (patch)
treeb38d310be53c6ecb3838cb308ea028922ab389d2 /sys-process
parentsys-process/htop: Bump to version 3.2.0 (diff)
downloadgentoo-8e81a3a72fa3c6dc0043bbb3cdbd54ed66f13bbe.tar.gz
gentoo-8e81a3a72fa3c6dc0043bbb3cdbd54ed66f13bbe.tar.bz2
gentoo-8e81a3a72fa3c6dc0043bbb3cdbd54ed66f13bbe.zip
sys-process/htop: Removed old
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/htop/Manifest2
-rw-r--r--sys-process/htop/htop-3.0.5-r2.ebuild77
-rw-r--r--sys-process/htop/htop-3.1.1-r1.ebuild99
3 files changed, 0 insertions, 178 deletions
diff --git a/sys-process/htop/Manifest b/sys-process/htop/Manifest
index 1e8c23f8a542..a321ed370318 100644
--- a/sys-process/htop/Manifest
+++ b/sys-process/htop/Manifest
@@ -1,4 +1,2 @@
-DIST htop-3.0.5.tar.gz 297931 BLAKE2B a6e62f99ef349809d11bb14b4d515036601aa457507b34a96354607f136cc4e0d3d40a715f1576c70833db051d989fa55142b4f8bba0f5f432ea3676364d9575 SHA512 7dae83ceff6b3f30e69c30c9559dbb3bf69281df006c6a26e4e2c49dd5a147e05ed7bafeeac8ec5bedc8ba670470100cc128209a92654858f98df09a9394594f
-DIST htop-3.1.1.tar.gz 381277 BLAKE2B 4383991e8821e4c27a4f5cb002b198fa7915465c03d9fb83324fa2df732d8553be4061c2c559b92de934b0c214bb4445b068795050e1bee2afb803d7f32b9a67 SHA512 5e4ec9b5fdf4583c8a345dcc2fe9395737e3a6e8dd8e6547800b959be084b9d57ae30bf891f79a25f6bf99ec0b6eb7eaba8bc851072c5a550de70df4178dc07d
DIST htop-3.1.2.tar.gz 387656 BLAKE2B a9682b6f3475fbae6ab7fd57330271190ec32267c5a8f2aac845cd18c566eaa9beed642c1e67fbc9606f120df600c27ed2ef0480a29ef304875a99898c1f10e4 SHA512 7e08b820042e480ca61137ff24b468804b49b95c1bbedaf82029dd79d29c2c541c5211284ec075692203788bbb868a9d4326ffd24c68419e22eec13ae5012700
DIST htop-3.2.0.tar.gz 393712 BLAKE2B fff50fce1dd58d5738ca4a75a8b4078aa34e9544798c81bb18a2674823ab13a93ecec8c00d034704ecaab6a871efa2b021550dc1f0a03aa86f638c28e84f769e SHA512 174eaa7333fa60e40f67148560c53125e7aaf46a48e7f3ecfa2daa68553c94b3d076d03320afd479dcee07e739c0ff286a81b67cbc994782c33e798d3ed4605c
diff --git a/sys-process/htop/htop-3.0.5-r2.ebuild b/sys-process/htop/htop-3.0.5-r2.ebuild
deleted file mode 100644
index 6249887e7d60..000000000000
--- a/sys-process/htop/htop-3.0.5-r2.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit autotools linux-info python-any-r1 xdg-utils
-
-DESCRIPTION="interactive process viewer"
-HOMEPAGE="https://htop.dev/ https://github.com/htop-dev/htop"
-SRC_URI="https://github.com/htop-dev/${PN}/archive/${PV/_}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-IUSE="debug hwloc lm-sensors openvz unicode vserver"
-
-BDEPEND="virtual/pkgconfig"
-RDEPEND="sys-libs/ncurses:=[unicode(+)?]
- hwloc? ( sys-apps/hwloc:= )
- lm-sensors? ( sys-apps/lm-sensors )"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}"
-
-DOCS=( ChangeLog README )
-
-CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
-
-S="${WORKDIR}/${P/_}"
-
-pkg_setup() {
- if ! has_version sys-process/lsof; then
- ewarn "To use lsof features in htop (what processes are accessing"
- ewarn "what files), you must have sys-process/lsof installed."
- fi
-
- python-any-r1_pkg_setup
- linux-info_pkg_setup
-}
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- [[ ${CBUILD} != ${CHOST} ]] && export ac_cv_file__proc_{meminfo,stat}=yes #328971
-
- local myeconfargs=(
- $(use_enable debug)
- $(use_enable hwloc)
- $(use_enable openvz)
- $(use_enable unicode)
- $(use_enable vserver)
- $(use_with lm-sensors sensors)
- )
-
- if ! use hwloc && use kernel_linux ; then
- myeconfargs+=( --enable-linux-affinity )
- else
- myeconfargs+=( --disable-linux-affinity )
- fi
-
- econf ${myeconfargs[@]}
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}
diff --git a/sys-process/htop/htop-3.1.1-r1.ebuild b/sys-process/htop/htop-3.1.1-r1.ebuild
deleted file mode 100644
index 807d51af35fe..000000000000
--- a/sys-process/htop/htop-3.1.1-r1.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit autotools linux-info python-any-r1 xdg-utils
-
-DESCRIPTION="interactive process viewer"
-HOMEPAGE="https://htop.dev/ https://github.com/htop-dev/htop"
-SRC_URI="https://github.com/htop-dev/${PN}/archive/${PV/_}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-LICENSE="BSD GPL-2+"
-SLOT="0"
-IUSE="caps debug delayacct hwloc lm-sensors openvz unicode vserver"
-
-BDEPEND="virtual/pkgconfig"
-RDEPEND="
- sys-libs/ncurses:=[unicode(+)?]
- hwloc? ( sys-apps/hwloc:= )
- kernel_linux? (
- caps? ( sys-libs/libcap )
- delayacct? ( dev-libs/libnl:3 )
- lm-sensors? ( sys-apps/lm-sensors )
- )
-"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}"
-
-DOCS=( ChangeLog README )
-
-CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
-
-S="${WORKDIR}/${P/_}"
-
-pkg_setup() {
- if ! has_version sys-process/lsof; then
- ewarn "To use lsof features in htop (what processes are accessing"
- ewarn "what files), you must have sys-process/lsof installed."
- fi
-
- python-any-r1_pkg_setup
- linux-info_pkg_setup
-}
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- [[ ${CBUILD} != ${CHOST} ]] && export ac_cv_file__proc_{meminfo,stat}=yes #328971
-
- local myeconfargs=(
- --enable-unicode
- $(use_enable debug)
- $(use_enable hwloc)
- $(use_enable !hwloc affinity)
- $(use_enable openvz)
- $(use_enable unicode)
- $(use_enable vserver)
- )
-
- if use kernel_linux ; then
- myeconfargs+=(
- $(use_enable caps capabilities)
- $(use_enable delayacct)
- $(use_enable lm-sensors sensors)
- )
- else
- if use kernel_Darwin ; then
- # Upstream default to checking but --enable-affinity
- # overrides this. Simplest to just disable on Darwin
- # given it works on BSD anyway.
- myeconfargs+=( --disable-affinity )
- fi
-
- myeconfargs+=(
- --disable-capabilities
- --disable-delayacct
- --disable-sensors
- )
- fi
-
- econf ${myeconfargs[@]}
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}