summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-02-05 16:07:49 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-02-05 16:12:41 +0100
commitd132a1abba93e343616592e513c0f384c74f8e73 (patch)
treef0ec5cde4751ca23f68723692dffb73b68dd5ada /sys-process
parentwww-client/vivaldi-snapshot: Version 1.15.1090.3_p1. (diff)
downloadgentoo-d132a1abba93e343616592e513c0f384c74f8e73.tar.gz
gentoo-d132a1abba93e343616592e513c0f384c74f8e73.tar.bz2
gentoo-d132a1abba93e343616592e513c0f384c74f8e73.zip
sys-process/htop: Bump to version 2.1.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/htop/Manifest1
-rw-r--r--sys-process/htop/files/htop-2.1.0-sysmacros.patch38
-rw-r--r--sys-process/htop/htop-2.1.0.ebuild59
3 files changed, 98 insertions, 0 deletions
diff --git a/sys-process/htop/Manifest b/sys-process/htop/Manifest
index bf53ce06053a..72879e96ad04 100644
--- a/sys-process/htop/Manifest
+++ b/sys-process/htop/Manifest
@@ -1,3 +1,4 @@
DIST htop-1.0.3.tar.gz 399306 BLAKE2B 3ce3aad0f72102c2aa6d9c7a198eef5e1591dec41f6fabfbe03f2626e08d0967c023adba8285c94e5b5ac05d3b05ec78964035f0bd70bbdff9f429f9cb052097 SHA512 4c5c784b093bcad06eb2e8d8bb215e14f6e838a3d47d8da8402344c270c1724f85d0bcde2899571ba5d0e5a02274a0c3390a76fed61785b2604b51351f08f232
DIST htop-2.0.1.tar.gz 477196 BLAKE2B 03b6d7a71cbf261413e828d8678daecc969c76439a1241734d7bed13f7f8a3d22b40ebc4845c924ea6c61ddae20f1b90f78790c634908cf4d161ecb314e57c72 SHA512 57991a55b69028c01549b067ec749099466df5b08a0ed9a65dd779e6d2c8ee0a5d9c330bb6c727b04a349146ad441b7115718e433d1f8232f74b28903fb351ff
DIST htop-2.0.2.tar.gz 476364 BLAKE2B f5519977b4bd6d189cb7f379a9f9b535a4b67a575b30056a43e259ab39a69f84083d310bbefefe8408c7ca99918f1ea9ae775808b9afe9d0f78097ac6bb88dc7 SHA512 1c9bf71a36c56b301667aa6d03756fc757fbcb63e848d9581d10db3df6193cdeb00e55ceb6e2392794ac03ea034b04459a8fe550b3ac2318cd86263a74c78cda
+DIST htop-2.1.0.tar.gz 302938 BLAKE2B 3e290a3dbb0bf5424780ba5dcb9de8ea478bf4cabbbde202c19eb3db7e0f8d1e108ec3ea41544ac095097c39100417c72477dab96f104a6317f4edd06d69199f SHA512 203e8f4abd63334330fc673f6c9609adbeab763d80f553d8b48670091d18dd347599a9ce2dbbac374fa4a13fa904948711a441fa676f52ab1612bd2b4ee4c6eb
diff --git a/sys-process/htop/files/htop-2.1.0-sysmacros.patch b/sys-process/htop/files/htop-2.1.0-sysmacros.patch
new file mode 100644
index 000000000000..08f023b442e5
--- /dev/null
+++ b/sys-process/htop/files/htop-2.1.0-sysmacros.patch
@@ -0,0 +1,38 @@
+From 25c50af220c2de4542b440b7470a644caf2a3b65 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Mon, 5 Feb 2018 16:02:19 +0100
+Subject: [PATCH] Add <sys/sysmacros.h> to two files.
+
+Future glibc releases will no longer include sysmacros implicitly.
+---
+ Process.c | 1 +
+ linux/LinuxProcessList.c | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/Process.c b/Process.c
+index 1836080..5122afb 100644
+--- a/Process.c
++++ b/Process.c
+@@ -19,6 +19,7 @@ in the source distribution for its full text.
+ #include <sys/param.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <signal.h>
+diff --git a/linux/LinuxProcessList.c b/linux/LinuxProcessList.c
+index 6f2631a..7522fb1 100644
+--- a/linux/LinuxProcessList.c
++++ b/linux/LinuxProcessList.c
+@@ -25,6 +25,7 @@ in the source distribution for its full text.
+ #include <time.h>
+ #include <assert.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <fcntl.h>
+
+ #ifdef HAVE_DELAYACCT
+--
+2.16.1
+
diff --git a/sys-process/htop/htop-2.1.0.ebuild b/sys-process/htop/htop-2.1.0.ebuild
new file mode 100644
index 000000000000..1ba6ab8008f8
--- /dev/null
+++ b/sys-process/htop/htop-2.1.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools linux-info
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://hisham.hm/htop/"
+SRC_URI="http://hisham.hm/htop/releases/${PV}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="kernel_FreeBSD kernel_linux openvz unicode vserver"
+
+RDEPEND="sys-libs/ncurses:0=[unicode?]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( ChangeLog README )
+
+CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
+
+PATCHES=(
+ "${FILESDIR}/${P}-sysmacros.patch"
+)
+
+pkg_setup() {
+ if ! has_version sys-process/lsof; then
+ ewarn "To use lsof features in htop(what processes are accessing"
+ ewarn "what files), you must have sys-process/lsof installed."
+ fi
+
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ rm missing || die
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ [[ $CBUILD != $CHOST ]] && export ac_cv_file__proc_{meminfo,stat}=yes #328971
+
+ local myeconfargs=(
+ # fails to build against recent hwloc versions
+ --disable-hwloc
+ --enable-taskstats
+ $(use_enable kernel_linux cgroup)
+ $(use_enable kernel_linux linux-affinity)
+ $(use_enable openvz)
+ $(use_enable unicode)
+ $(use_enable vserver)
+ )
+ econf ${myeconfargs[@]}
+}