summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /virtual/ffmpeg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'virtual/ffmpeg')
-rw-r--r--virtual/ffmpeg/ffmpeg-0.10.3-r1.ebuild20
-rw-r--r--virtual/ffmpeg/ffmpeg-0.10.3.ebuild22
-rw-r--r--virtual/ffmpeg/ffmpeg-9-r1.ebuild24
-rw-r--r--virtual/ffmpeg/ffmpeg-9-r2.ebuild29
-rw-r--r--virtual/ffmpeg/ffmpeg-9.ebuild22
-rw-r--r--virtual/ffmpeg/metadata.xml11
6 files changed, 128 insertions, 0 deletions
diff --git a/virtual/ffmpeg/ffmpeg-0.10.3-r1.ebuild b/virtual/ffmpeg/ffmpeg-0.10.3-r1.ebuild
new file mode 100644
index 000000000000..05090af222e8
--- /dev/null
+++ b/virtual/ffmpeg/ffmpeg-0.10.3-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Virtual package for FFmpeg implementation"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="X +encode gsm jpeg2k libav mp3 sdl speex theora threads truetype vaapi vdpau x264"
+
+RDEPEND="
+ !libav? ( >=media-video/ffmpeg-0.10.3:0[X?,encode?,gsm?,jpeg2k?,mp3?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?] )
+ libav? ( >=media-video/libav-0.8.4[X?,encode?,gsm?,jpeg2k?,mp3?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?] )
+"
+DEPEND=""
diff --git a/virtual/ffmpeg/ffmpeg-0.10.3.ebuild b/virtual/ffmpeg/ffmpeg-0.10.3.ebuild
new file mode 100644
index 000000000000..01dcf16f3300
--- /dev/null
+++ b/virtual/ffmpeg/ffmpeg-0.10.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Virtual package for FFmpeg implementation"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="X +encode gsm jpeg2k mp3 sdl speex theora threads truetype vaapi vdpau x264"
+
+RDEPEND="
+ || (
+ >=media-video/ffmpeg-0.10.3:0[X?,encode?,gsm?,jpeg2k?,mp3?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?]
+ >=media-video/libav-0.8.4[X?,encode?,gsm?,jpeg2k?,mp3?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?]
+ )
+"
+DEPEND=""
diff --git a/virtual/ffmpeg/ffmpeg-9-r1.ebuild b/virtual/ffmpeg/ffmpeg-9-r1.ebuild
new file mode 100644
index 000000000000..4748b35e52af
--- /dev/null
+++ b/virtual/ffmpeg/ffmpeg-9-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib-build
+
+DESCRIPTION="Virtual package for FFmpeg implementation"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="X +encode gsm jpeg2k mp3 opus sdl speex theora threads truetype vaapi vdpau x264"
+
+RDEPEND="
+ || (
+ >=media-video/libav-9.12[${MULTILIB_USEDEP},X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?]
+ >=media-video/ffmpeg-1.2.6-r1:0[${MULTILIB_USEDEP},X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?]
+ )
+"
+DEPEND=""
diff --git a/virtual/ffmpeg/ffmpeg-9-r2.ebuild b/virtual/ffmpeg/ffmpeg-9-r2.ebuild
new file mode 100644
index 000000000000..cf3fd4ce34b8
--- /dev/null
+++ b/virtual/ffmpeg/ffmpeg-9-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib-build
+
+DESCRIPTION="Virtual package for FFmpeg executable implementation"
+HOMEPAGE=""
+SRC_URI=""
+
+# Please note that this virtual is only suited for packages that call
+# ffmpeg/avconv or one of the remaining executables. If your package
+# links to one of the libraries, you need to use the following
+# dependency instead (adding IUSE=libav):
+# libav? ( media-video/libav:0= )
+# !libav? ( media-video/ffmpeg:0= )
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="X +encode gsm jpeg2k libav mp3 opus sdl speex theora threads truetype vaapi vdpau x264"
+
+RDEPEND="
+ libav? ( >=media-video/libav-9.12[${MULTILIB_USEDEP},X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?] )
+ !libav? ( >=media-video/ffmpeg-1.2.6-r1:0[${MULTILIB_USEDEP},X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?] )
+"
+DEPEND=""
diff --git a/virtual/ffmpeg/ffmpeg-9.ebuild b/virtual/ffmpeg/ffmpeg-9.ebuild
new file mode 100644
index 000000000000..641e3ec6d6d1
--- /dev/null
+++ b/virtual/ffmpeg/ffmpeg-9.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Virtual package for FFmpeg implementation"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="X +encode gsm jpeg2k mp3 opus sdl speex theora threads truetype vaapi vdpau x264"
+
+RDEPEND="
+ || (
+ >=media-video/libav-9[X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?]
+ >=media-video/ffmpeg-1.0:0[X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?]
+ )
+"
+DEPEND=""
diff --git a/virtual/ffmpeg/metadata.xml b/virtual/ffmpeg/metadata.xml
new file mode 100644
index 000000000000..4ca5bff578d8
--- /dev/null
+++ b/virtual/ffmpeg/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>video</herd>
+<maintainer>
+ <email>media-video@gentoo.org</email>
+</maintainer>
+<use>
+ <flag name="opus">Use the external opus library for encoding and decoding.</flag>
+</use>
+</pkgmetadata>