summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-04-10 14:22:24 +0100
committerMarek Szuba <marecki@gentoo.org>2020-04-10 14:22:24 +0100
commita821e4e7964589d5f9cfbe8e36b5e46450ae2ca4 (patch)
tree899c9627aa77292dd3bb1a8e4a5159b210e6299a /virtual/opencl
parentvirtual/opencl: add dev-libs/opencl-icd-loader as alternative provider (diff)
downloadgentoo-a821e4e7964589d5f9cfbe8e36b5e46450ae2ca4.tar.gz
gentoo-a821e4e7964589d5f9cfbe8e36b5e46450ae2ca4.tar.bz2
gentoo-a821e4e7964589d5f9cfbe8e36b5e46450ae2ca4.zip
virtual/opencl: do not install README.gentoo
Having the list of available OpenCL runtimes stored in README.gentoo, which was suggested during reviews of opencl-3 on gentoo-dev, unfortunately violates the policy demanding virtuals not to install any files. Revert to the original approach of using elog in pkg_postinst directly. Closes: https://bugs.gentoo.org/716924 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'virtual/opencl')
-rw-r--r--virtual/opencl/files/README.gentoo18
-rw-r--r--virtual/opencl/opencl-3-r1.ebuild36
-rw-r--r--virtual/opencl/opencl-3.ebuild24
3 files changed, 36 insertions, 42 deletions
diff --git a/virtual/opencl/files/README.gentoo b/virtual/opencl/files/README.gentoo
deleted file mode 100644
index aa2dc0ef5190..000000000000
--- a/virtual/opencl/files/README.gentoo
+++ /dev/null
@@ -1,18 +0,0 @@
-In order to take advantage of OpenCL you will need a runtime for your hardware.
-Currently included in Gentoo are:
-
- * open:
- - dev-libs/intel-neo - integrated Intel GPUs from Broadwell onwards. 64-bit only;
- - dev-libs/rocm-opencl-runtime - AMD GPUs supported by the amdgpu kernel driver.
- Image support still requires a proprietary extension [1]. 64-bit only;
- - media-libs/mesa[opencl] - some older AMD GPUs; see [2]. 32-bit support;
-
- * proprietary:
- - dev-libs/amdgpu-pro-opencl - AMD Polaris GPUs. 32-bit support;
- - dev-util/intel-ocl-sdk - Intel CPUs (*not* GPUs). 64-bit only;
- - x11-drivers/nvidia-drivers[uvm] - Nvidia GPUs; specific package versions
- required for older devices [3]. 32-bit support.
-
- [1] dev-libs/hsa-ext-rocr
- [2] https://dri.freedesktop.org/wiki/GalliumCompute/
- [3] https://www.nvidia.com/en-us/drivers/unix/legacy-gpu/
diff --git a/virtual/opencl/opencl-3-r1.ebuild b/virtual/opencl/opencl-3-r1.ebuild
new file mode 100644
index 000000000000..3a288d129429
--- /dev/null
+++ b/virtual/opencl/opencl-3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for OpenCL API"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="|| ( dev-libs/ocl-icd[khronos-headers,${MULTILIB_USEDEP}]
+ dev-libs/opencl-icd-loader[${MULTILIB_USEDEP}] )"
+
+pkg_postinst() {
+ elog
+ elog "In order to take advantage of OpenCL you will need a runtime for your hardware."
+ elog "Currently included in Gentoo are:"
+ elog
+ elog " * open:"
+ elog " - dev-libs/intel-neo - integrated Intel GPUs from Broadwell onwards. 64-bit only;"
+ elog " - dev-libs/rocm-opencl-runtime - AMD GPUs supported by the amdgpu kernel driver."
+ elog " Image support still requires a proprietary extension [1]. 64-bit only;"
+ elog " - media-libs/mesa[opencl] - some older AMD GPUs; see [2]. 32-bit support;"
+ elog
+ elog " * proprietary:"
+ elog " - dev-libs/amdgpu-pro-opencl - AMD Polaris GPUs. 32-bit support;"
+ elog " - dev-util/intel-ocl-sdk - Intel CPUs (*not* GPUs). 64-bit only;"
+ elog " - x11-drivers/nvidia-drivers[uvm] - Nvidia GPUs; specific package versions"
+ elog " required for older devices [3]. 32-bit support."
+ elog
+ elog " [1] dev-libs/hsa-ext-rocr"
+ elog " [2] https://dri.freedesktop.org/wiki/GalliumCompute/"
+ elog " [3] https://www.nvidia.com/en-us/drivers/unix/legacy-gpu/"
+ elog
+}
diff --git a/virtual/opencl/opencl-3.ebuild b/virtual/opencl/opencl-3.ebuild
deleted file mode 100644
index baa33caadb73..000000000000
--- a/virtual/opencl/opencl-3.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib-build readme.gentoo-r1
-
-DESCRIPTION="Virtual for OpenCL API"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="|| ( dev-libs/ocl-icd[khronos-headers,${MULTILIB_USEDEP}]
- dev-libs/opencl-icd-loader[${MULTILIB_USEDEP}] )"
-
-# so that src_install() doesn't fail on missing directory
-S="${WORKDIR}"
-
-src_install() {
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}