summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-04-01 21:43:11 +0100
committerMarek Szuba <marecki@gentoo.org>2020-04-01 22:14:57 +0100
commitf0cb6e744add38bf4d3a05c0703dabb1f8ee4e5d (patch)
treef6707b89688aa478ea77baa436459e9b28bfd376 /virtual/opencl
parentwww-client/firefox: fix typo (diff)
downloadgentoo-f0cb6e744add38bf4d3a05c0703dabb1f8ee4e5d.tar.gz
gentoo-f0cb6e744add38bf4d3a05c0703dabb1f8ee4e5d.tar.bz2
gentoo-f0cb6e744add38bf4d3a05c0703dabb1f8ee4e5d.zip
virtual/opencl: add dev-libs/ocl-icd as the fallback provider
Advantages: * keyworded x86 * supports multilib on amd64 * all OpenCL-aware software should compile and link fine against it * should make it easier for user to deploy out-of-tree OpenCL providers (side note: all actual OpenCL providers currently in the tree except x11-drivers/nvidia-drivers actually *require* this to work), should they choose to do so Disadvantages: * essentially a hack to ensure the integrity of the dependency tree on x86 and amd64/abi_x86_32 - most of the actual OpenCL providers currently in the tree are 64-bit only anyway Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'virtual/opencl')
-rw-r--r--virtual/opencl/opencl-2.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/virtual/opencl/opencl-2.ebuild b/virtual/opencl/opencl-2.ebuild
index 2e7f07912347..50fcd113e316 100644
--- a/virtual/opencl/opencl-2.ebuild
+++ b/virtual/opencl/opencl-2.ebuild
@@ -12,6 +12,9 @@ CARDS=( amdgpu i965 nvidia r600 radeonsi )
IUSE="${CARDS[@]/#/video_cards_}"
# intel-neo and intel-ocl-sdk are amd64-only
+# ocl-icd is essentially a dummy/you-are-on-your-own provider - it installs
+# header files to include in the source code and a library to link against
+# but does not support any actual devices
RDEPEND="app-eselect/eselect-opencl
|| (
video_cards_i965? (
@@ -28,4 +31,5 @@ RDEPEND="app-eselect/eselect-opencl
video_cards_radeonsi? (
>=media-libs/mesa-9.1.6[opencl,X(+),${MULTILIB_USEDEP}] )
abi_x86_64? ( !abi_x86_32? ( dev-util/intel-ocl-sdk ) )
+ dev-libs/ocl-icd[khronos-headers,${MULTILIB_USEDEP}]
)"