summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-03-11 13:43:35 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-03-11 13:52:14 +0100
commit57decee9b344493248c9b517d09a5d8069debbb9 (patch)
tree61fd17954e48c427ad9b9960b1de598f98b8bcbd /virtual/python-singledispatch
parentsys-kernel/vanilla-sources: Automated version bump to {4.4.216,4.9.216} - rem... (diff)
downloadgentoo-57decee9b344493248c9b517d09a5d8069debbb9.tar.gz
gentoo-57decee9b344493248c9b517d09a5d8069debbb9.tar.bz2
gentoo-57decee9b344493248c9b517d09a5d8069debbb9.zip
virtual/python-singledispatch: add PyPy3 support
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'virtual/python-singledispatch')
-rw-r--r--virtual/python-singledispatch/python-singledispatch-0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/virtual/python-singledispatch/python-singledispatch-0.ebuild b/virtual/python-singledispatch/python-singledispatch-0.ebuild
index 8f81fd4f9773..2679d59fd8df 100644
--- a/virtual/python-singledispatch/python-singledispatch-0.ebuild
+++ b/virtual/python-singledispatch/python-singledispatch-0.ebuild
@@ -3,7 +3,7 @@
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+PYTHON_COMPAT=( pypy3 python2_7 python3_{6,7,8} )
inherit python-r1
@@ -13,4 +13,4 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ppc ppc64 s390 sparc x86 ~amd64-linux
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- $(python_gen_cond_dep 'dev-python/singledispatch[${PYTHON_USEDEP}]' python2_7 pypy)"
+ $(python_gen_cond_dep 'dev-python/singledispatch[${PYTHON_USEDEP}]' -2)"