summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-01 12:48:35 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-02 12:47:12 +0100
commit410c07b6f60d1e17f0171fed64fe580ba1f4a124 (patch)
treea5602c5565f4e78344d01ae1fc8c826374a0d96e /virtual
parentvirtual/dnspython: Fix dependency on python ABIs (diff)
downloadgentoo-410c07b6f60d1e17f0171fed64fe580ba1f4a124.tar.gz
gentoo-410c07b6f60d1e17f0171fed64fe580ba1f4a124.tar.bz2
gentoo-410c07b6f60d1e17f0171fed64fe580ba1f4a124.zip
virtual/funcsigs: Add missing keywords and py ABIs
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'virtual')
-rw-r--r--virtual/funcsigs/funcsigs-0.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/virtual/funcsigs/funcsigs-0.ebuild b/virtual/funcsigs/funcsigs-0.ebuild
index 6674d0ca0aa9..c811a39f5d10 100644
--- a/virtual/funcsigs/funcsigs-0.ebuild
+++ b/virtual/funcsigs/funcsigs-0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_{3,4}} )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
inherit python-r1
@@ -14,11 +14,12 @@ SRC_URI=""
SLOT="0"
LICENSE=""
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
${PYTHON_DEPS}
- $(python_gen_cond_dep 'dev-python/funcsigs' python2_7)"
+ $(python_gen_cond_dep 'dev-python/funcsigs' python2_7 pypy )"
+DEPEND=""