summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-29 23:35:12 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-30 01:59:15 -0800
commit772470aed21cbb55386e12b8cf02d4ffb5be896a (patch)
tree17b794b211838a2a00e009c4ac82a06a61346667 /virtual
parentdev-lang/rust: revbump 1.40.0 with fixes (diff)
downloadgentoo-772470aed21cbb55386e12b8cf02d4ffb5be896a.tar.gz
gentoo-772470aed21cbb55386e12b8cf02d4ffb5be896a.tar.bz2
gentoo-772470aed21cbb55386e12b8cf02d4ffb5be896a.zip
virtual/rust: add multilib for 1.40.0
Closes: https://github.com/gentoo/gentoo/pull/14177 Bug: https://bugs.gentoo.org/701362 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'virtual')
-rw-r--r--virtual/rust/rust-1.40.0.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/virtual/rust/rust-1.40.0.ebuild b/virtual/rust/rust-1.40.0.ebuild
index 64c77a7fa4e9..a267eb017c2d 100644
--- a/virtual/rust/rust-1.40.0.ebuild
+++ b/virtual/rust/rust-1.40.0.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit multilib-build
+
DESCRIPTION="Virtual for Rust language compiler"
LICENSE=""
@@ -10,4 +12,4 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
BDEPEND=""
-RDEPEND="|| ( =dev-lang/rust-${PV}* =dev-lang/rust-bin-${PV}* )"
+RDEPEND="|| ( =dev-lang/rust-${PV}*[${MULTILIB_USEDEP}] =dev-lang/rust-bin-${PV}* )"