summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_layout
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_layout')
-rw-r--r--www-apache/mod_layout/Manifest1
-rw-r--r--www-apache/mod_layout/files/15_mod_layout.conf148
-rw-r--r--www-apache/mod_layout/metadata.xml5
-rw-r--r--www-apache/mod_layout/mod_layout-5.1.ebuild26
4 files changed, 180 insertions, 0 deletions
diff --git a/www-apache/mod_layout/Manifest b/www-apache/mod_layout/Manifest
new file mode 100644
index 000000000000..58dc3346f5f4
--- /dev/null
+++ b/www-apache/mod_layout/Manifest
@@ -0,0 +1 @@
+DIST mod_layout-5.1.tar.gz 12798 SHA256 d00299e3aae38704096477377d20a5c5bcc32fe7802044358a79a31248cd23c6 SHA512 c4a9273da116a1c21356bbd3c8abd6b6ff82604fb5b5a01fd72e41ef8cc77427ad12d395436af894f4b10a227025d1dd45f68150ae6bad073d60820ac6753014 WHIRLPOOL b9966f313c134b6a498793bb2cc8a6a93ab7f604ad62ebee1d23821195265e7c97715172f5481e1ca204790bb112272f8b410a861b54b8f7838523862823ad8f
diff --git a/www-apache/mod_layout/files/15_mod_layout.conf b/www-apache/mod_layout/files/15_mod_layout.conf
new file mode 100644
index 000000000000..5e652ae1cab1
--- /dev/null
+++ b/www-apache/mod_layout/files/15_mod_layout.conf
@@ -0,0 +1,148 @@
+<IfDefine LAYOUT>
+LoadModule layout_module modules/mod_layout.so
+
+<Directory /home/*/public_html>
+# This default configuration adds a footer to every html page in ~user
+# "Powered by Gentoo Linux"
+
+# Enable the filter for all text/html pages
+# use LayoutHandler for Apache1 and AddOutputFilter for Apache2
+#LayoutHandler text/html
+#AddOutputFilterByType LAYOUT text/html
+
+# This directives makes sure that all Layout headers and footers
+# get Cache-Control: no-cache methods in all situations. This
+# directive either takes On or Off."
+# LayoutCacheNeeded
+
+# A URI which prints the header contents.
+# LayoutHeader
+
+# A URI which prints the footer contents.
+LayoutFooter "<p>Powered by <a href='http://www.gentoo.org'>Gentoo Linux</a></p>"
+
+# Add a layout to be inserted when a tag is found, this takes two
+# options, with a third optional parameter. The first is a pattern,
+# the second is the layout and the third is how the layout should be
+# inserts (either prepend, append, or replace). The default is to
+# replace.
+# Layout "<-- replace_me -->" "<p>Visit: <a href=http://www.gentoo.org/>Gentoo Linux</a></p>" replace
+
+# Enter a URI that should be ignored, regular expressions are allowed.
+# LayoutIgnoreURI
+
+# Enter a URI that should be ignored by the header, regular expressions
+# are allowed.
+# LayoutIgnoreHeaderURI
+
+# Enter a URI that should be ignored by the HTTPHeader, regular
+# expressions are allowed.
+# LayoutIgnoreHTTPHeaderURI
+
+# Enter a URI that should be ignored by the footer, regular expressions
+# are allowed.
+# LayoutIgnoreFooterURI
+
+# This can either be On or Off (default it Off). It places HTML comments
+# in the outbound text describing when and where mod_layout has been
+# inserting text.
+LayoutComment On
+
+# This can either be On or Off (default it Off). This is both
+# experimental and probably quite broke.
+# LayoutProxy
+
+# This can either be On or Off (default it On). When off the original
+# document is not displayed.
+# LayoutDisplayOriginal
+
+# Turns On (default) or Off a list of standard types to handle.
+# LayoutDefaultHandlers
+
+# This takes a SSI style timme format that can be used to change the
+# output by mod_layout's internal TIME environmental variables that
+# it introduces.
+# LayoutTimeFormat
+
+# Takes a URI to call for the HTTP Header.
+# LayoutHTTPHeader
+
+# Specify handlers that mod_layout should produce HTTP headers for.
+# LayoutHTTPOverrideHandler
+
+# Specify URI's that mod_layout should produce HTTP headers for.
+# LayoutHTTPOverrideURI
+
+# This takes no arguments. If found it will turn off the footer.
+# LayoutFooterOff
+
+# This takes no arguments. If found it will turn off the header.
+# LayoutHeaderOff
+
+# This takes no arguments. If found it will turn off the http header.
+# LayoutHTTPHeaderOff
+
+# Turns on and off asynchronous POSTs (AKA everything can see the post
+# data).
+# LayoutPostAsync
+
+# This moves the default cache from /tmp to another directory(or a
+# RAM disk).
+# LayoutCache
+
+# Turning this On or Off afffects whether or not headers and footers
+# are appended when creating subsections.
+# LayoutAppend
+
+# Turning this on and off will tell mod_layout to attempt to resolve
+# content (do a merger of the footer, body and header text
+# LayoutMerge
+
+# Use this to change the default begin tag to use during merges (the
+# default string is \<HTML>\
+# LayoutMergeBeginTag
+
+# Use this to change the default end tag to use during merges (the
+# default string is \<\\HTML>\
+# LayoutMergeEndTag
+
+# Use this to change the default end tag to use during merges (the
+# default string is \<\\HTML>\
+# LayoutHeaderAppend
+
+# Use this to change the default end tag to use during merges (the
+# default string is \<\\HTML>\
+# LayoutFooterAppend
+
+# When enabled (it takes on and off flags) mod_layout will not try
+# to wrap any errors. Merge must be enabled for this to work. The
+# default for this is off.
+# LayoutMergeErrorIgnore
+
+# If this tag is found during a merge, no footer or header will be
+# inserted into the document
+# LayoutIgnoreTag
+
+# If this tag is found during a merge, no footer will be inserted
+# into the document
+# LayoutIgnoreTagFooter
+
+# If this tag is found during a merge, no header will be inserted
+# into the document
+# LayoutIgnoreTagHeader
+
+# This turns on mod_layout's own text/html and text/plain handler
+# LayoutHTMLHandler
+
+# If this is enabled and you are doing a merge, the tags used for the
+# merge will be replaced.
+# LayoutReplaceTags
+
+# If you want applications to do notes (a set of directives to control
+# actions inside apache).
+# LayoutNotes
+
+</Directory>
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_layout/metadata.xml b/www-apache/mod_layout/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/www-apache/mod_layout/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_layout/mod_layout-5.1.ebuild b/www-apache/mod_layout/mod_layout-5.1.ebuild
new file mode 100644
index 000000000000..d8b4a8d602ac
--- /dev/null
+++ b/www-apache/mod_layout/mod_layout-5.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit apache-module
+
+DESCRIPTION="An Apache2 module for adding custom headers and/or footers"
+HOMEPAGE="http://tangent.org/index.pl?node_id=362"
+SRC_URI="http://download.tangent.org/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+APXS2_ARGS="-c ${PN}.c utility.c layout.c"
+
+APACHE2_MOD_CONF="15_mod_layout"
+APACHE2_MOD_DEFINE="LAYOUT"
+
+DOCFILES="README"
+
+need_apache2_2