summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_log_rotate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_log_rotate')
-rw-r--r--www-apache/mod_log_rotate/Manifest2
-rw-r--r--www-apache/mod_log_rotate/files/10_mod_log_rotate.conf6
-rw-r--r--www-apache/mod_log_rotate/metadata.xml10
-rw-r--r--www-apache/mod_log_rotate/mod_log_rotate-1.00.ebuild22
-rw-r--r--www-apache/mod_log_rotate/mod_log_rotate-1.01.ebuild25
5 files changed, 65 insertions, 0 deletions
diff --git a/www-apache/mod_log_rotate/Manifest b/www-apache/mod_log_rotate/Manifest
new file mode 100644
index 000000000000..5a2b15447e68
--- /dev/null
+++ b/www-apache/mod_log_rotate/Manifest
@@ -0,0 +1,2 @@
+DIST mod_log_rotate-1.00.tar.bz2 4697 SHA256 8a46b9ebecee09ff3dc240dcc28f153b66135764b80e374de60a0a4f1301eb5a SHA512 dbfa1399f70333e6d53cee039ba9c81a213b485a8a6824976983ebc85b2c856061dbbc13fa899b5e98912c519c9fb37009bf2fbf8b6a9f46cca65c0e3bd1595e WHIRLPOOL 257b7d189e045913e31cea822bd137eaab3b052fb1b196a8b4057c02466c9fb55a3ed1929c5230d18a7d75f710f19691132b3062caf4f2ca0c4057e82be11be0
+DIST mod_log_rotate-1.01.tar.gz 9772 SHA256 c87465630591b938b2263abc566354befd263aea31ad045752a006de57584432 SHA512 7da606ae8ce5e0f2ade16fdffffc57fa9549b4b5e9529eb3149ff7390caa64f7ec065aa7416b5c8ab751e2b3eaf35cf79c96b8c7e68e1165a46851547781c076 WHIRLPOOL cfdd957f86f964b2c6dc0deb3c838d67a899d8e7ce6c4a9421930c77a6cbd2755aa4903acae371b3a36bada6dccdbdd876a41dc369610cadca04ff5ed875d7f6
diff --git a/www-apache/mod_log_rotate/files/10_mod_log_rotate.conf b/www-apache/mod_log_rotate/files/10_mod_log_rotate.conf
new file mode 100644
index 000000000000..eb17b4622ff1
--- /dev/null
+++ b/www-apache/mod_log_rotate/files/10_mod_log_rotate.conf
@@ -0,0 +1,6 @@
+<IfDefine LOG_ROTATE>
+LoadModule log_rotate_module modules/mod_log_rotate.so
+RotateLogs On
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_log_rotate/metadata.xml b/www-apache/mod_log_rotate/metadata.xml
new file mode 100644
index 000000000000..5c72380f8f41
--- /dev/null
+++ b/www-apache/mod_log_rotate/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">JBlond/mod_log_rotate</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-apache/mod_log_rotate/mod_log_rotate-1.00.ebuild b/www-apache/mod_log_rotate/mod_log_rotate-1.00.ebuild
new file mode 100644
index 000000000000..fb2b552b91b6
--- /dev/null
+++ b/www-apache/mod_log_rotate/mod_log_rotate-1.00.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils apache-module
+
+DESCRIPTION="mod_log_rotate adds log rotation support to mod_log_config based on strftime(3)"
+HOMEPAGE="http://www.hexten.net/wiki/index.php/Mod-log-rotate"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="LOG_ROTATE"
+
+need_apache2
diff --git a/www-apache/mod_log_rotate/mod_log_rotate-1.01.ebuild b/www-apache/mod_log_rotate/mod_log_rotate-1.01.ebuild
new file mode 100644
index 000000000000..dcf3bf05da58
--- /dev/null
+++ b/www-apache/mod_log_rotate/mod_log_rotate-1.01.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit apache-module
+
+DESCRIPTION="Log rotation support for mod_log_config based on strftime(3)"
+HOMEPAGE="https://github.com/JBlond/${PN}"
+SRC_URI="https://github.com/JBlond/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="LOG_ROTATE"
+DOCFILES="README.md"
+
+need_apache2