summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-06-27 00:51:08 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-06-27 00:59:43 +0200
commitf25832515153dcad71b42a635a27590f339846ee (patch)
tree142a40d88bfdb3881fe25ec5bb38c57142b6c59a /www-apache/mod_qos
parentwww-apache/mod_qos: bump to 11.65 (diff)
downloadgentoo-f25832515153dcad71b42a635a27590f339846ee.tar.gz
gentoo-f25832515153dcad71b42a635a27590f339846ee.tar.bz2
gentoo-f25832515153dcad71b42a635a27590f339846ee.zip
www-apache/mod_qos: migrate EAPI to EAPI=6
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-apache/mod_qos')
-rw-r--r--www-apache/mod_qos/mod_qos-11.65.ebuild21
1 files changed, 14 insertions, 7 deletions
diff --git a/www-apache/mod_qos/mod_qos-11.65.ebuild b/www-apache/mod_qos/mod_qos-11.65.ebuild
index b98be2bbb585..765632d044a6 100644
--- a/www-apache/mod_qos/mod_qos-11.65.ebuild
+++ b/www-apache/mod_qos/mod_qos-11.65.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit autotools apache-module
DESCRIPTION="A QOS module for the apache webserver"
@@ -29,26 +29,33 @@ DOCFILES="${S}/doc/*.txt ${S}/README.TXT"
need_apache2
src_prepare() {
- cd "${S}/tools" && eautoreconf
+ default
+
+ pushd "${S}"/tools &>/dev/null || die
+ eautoreconf
+ popd &>/dev/null || die
}
src_configure() {
- cd "${S}/tools" && econf
+ pushd "${S}"/tools &>/dev/null || die
+ econf
+ popd &>/dev/null || die
}
src_compile() {
apache-module_src_compile
- emake -C "${S}/tools"
+ emake -C "${S}"/tools
}
src_install() {
einfo "Installing Apache module ..."
- cd "${S}/tools"
+ pushd "${S}"/tools &>/dev/null || die
apache-module_src_install
+ popd &>/dev/null || die
einfo "Installing module utilities ..."
- emake -C "${S}/tools" install DESTDIR="${D}"
+ emake -C "${S}"/tools install DESTDIR="${D}"
# installing html documentation
- dohtml -r -x *.txt "${S}/doc/"
+ dohtml -r -x *.txt "${S}"/doc/
}