summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/modsec-flameeyes/modsec-flameeyes-99999999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/modsec-flameeyes/modsec-flameeyes-99999999.ebuild')
-rw-r--r--www-apache/modsec-flameeyes/modsec-flameeyes-99999999.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/www-apache/modsec-flameeyes/modsec-flameeyes-99999999.ebuild b/www-apache/modsec-flameeyes/modsec-flameeyes-99999999.ebuild
new file mode 100644
index 000000000000..886ca12cb625
--- /dev/null
+++ b/www-apache/modsec-flameeyes/modsec-flameeyes-99999999.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo git-2
+
+GITHUB_USER=Flameeyes
+GITHUB_PROJECT=${PN}
+
+EGIT_REPO_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}.git"
+
+DESCRIPTION="Flameeyes's Ruleset for ModSecurity"
+HOMEPAGE="http://www.flameeyes.eu/projects/modsec"
+#SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND=">=www-apache/mod_security-2.5.1"
+DEPEND=""
+
+RULESDIR=/etc/modsecurity/flameeyes
+
+DOC_CONTENTS="To enable the ruleset, define MODSEC_FLAMEEYES in
+/etc/conf.d/apache2.
+
+If you do not use www-apache/modsecurity-crs you want also to uncomment
+the init configuration file in /etc/apache2/modules/81_${PN}.conf."
+
+src_install() {
+ insinto "${RULESDIR}"
+ doins -r rules optional
+
+ dodoc README.md
+
+ cat - > "${T}/81_${PN}.conf" <<EOF
+<IfDefine MODSEC_FLAMEEYES>
+
+# Uncomment this if you don't use the CRS
+# Include /etc/modsecurity/flameeyes/optional/flameeyes_init.conf
+
+Include /etc/modsecurity/flameeyes/rules/*.conf
+
+# -*- apache -*-
+# vim: ts=4 filetype=apache
+
+EOF
+
+ insinto /etc/apache2/modules.d/
+ doins "${T}/81_${PN}.conf"
+
+ readme.gentoo_create_doc
+}