summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-07-18 09:16:47 -0400
committerCraig Andrews <candrews@gentoo.org>2019-07-18 09:17:36 -0400
commitb81a5cdb5719e5af5d3e09f07211c22a8a763fd9 (patch)
tree08a282da7168f4867f18ebf982a4a5e3a55e9ded /www-apache
parentsys-libs/ncurses: ia64 stable wrt bug #690050 (diff)
downloadgentoo-b81a5cdb5719e5af5d3e09f07211c22a8a763fd9.tar.gz
gentoo-b81a5cdb5719e5af5d3e09f07211c22a8a763fd9.tar.bz2
gentoo-b81a5cdb5719e5af5d3e09f07211c22a8a763fd9.zip
www-apache/mod_h2: 1.15.3 version bump
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-1.15.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index 870b228b3be1..597383125e0d 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -9,3 +9,4 @@ DIST mod_http2-1.14.1.tar.gz 1032989 BLAKE2B 15359369f8332d9f9d35cb43468b2cd0d98
DIST mod_http2-1.15.0.tar.gz 1036567 BLAKE2B 1ed9fdd7bf13c8ec7ac14b2cd0a109f0cd6e6d1eb8047e1cf6cd107143e23ebb6d9f9ef753942d44ec4d2168e0783dd23dd66b338d8631c504d4cd81b0287b83 SHA512 c3541c930ceee81dfbd688ea155561b6e06aa8ef486830a95e6cfa621f3589aa9c9e15661a4b81463cbe716d02dd28a574e3a74894a74d7c751c88894d378858
DIST mod_http2-1.15.1.tar.gz 1026120 BLAKE2B 724d09bfafc2fe6a288eeebd7fbdcbe2c3d3e146b0afae42ae72be16931904982b07fd55f4c96da6f8718b5058421813ecd186ac4b4161a74ea7b83c38394ed1 SHA512 3564e8e4cb896420b91669d710d70cdecbe45480078c790960fd7d8c788ac9b843517c2af0747932ad53eb048c39765c4ceb2b7de7e04a1bc7fcb57af0117eb9
DIST mod_http2-1.15.2.tar.gz 1037495 BLAKE2B a6e1afcea50034affc2d505445f0227688a448ef1979de19df42db2e277ba0b1904f249bc55a114901039ce503d164bde92d70d69e70ddf03e3708ee5dd96233 SHA512 c919e9cd2a959d3ccde697424dc40580d52a2620ee476fc675b9f30a030044c2f9872b282e4ab08d4d576c0c7ee08ca2baad5a1d9a456dbd6c007cfef9fca6b3
+DIST mod_http2-1.15.3.tar.gz 1039368 BLAKE2B 79016846a66b27698343621a9cde23746b5408e1c328c578562f0ad300337d7eedc9b1fbcd680be671c6b428aded48969c688df9a6fde7856546c8ab198584cc SHA512 e6d4051a7fd6f27202951ac6a3c0ecd282e0bc3a086d319463effd031f4acff32599a8b0958ed75d31299585b90fe227ac5cbbf28ded0bf93175d8a1cefbdd00
diff --git a/www-apache/mod_h2/mod_h2-1.15.3.ebuild b/www-apache/mod_h2/mod_h2-1.15.3.ebuild
new file mode 100644
index 000000000000..3e6d435d3f82
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-1.15.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.20[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}