summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-27 14:15:49 +0000
committerSam James <sam@gentoo.org>2021-11-27 14:15:49 +0000
commitc8c2c1671c6801a6693fda30f90aa1b61872e748 (patch)
tree0826bb146649f1348e41356632ea713ef4294174 /www-apache
parentdev-perl/Quota: Version bump 1.8.2 (diff)
downloadgentoo-c8c2c1671c6801a6693fda30f90aa1b61872e748.tar.gz
gentoo-c8c2c1671c6801a6693fda30f90aa1b61872e748.tar.bz2
gentoo-c8c2c1671c6801a6693fda30f90aa1b61872e748.zip
www-apache/mod_auth_tkt: add missing dies, use BDEPEND for Perl
We use BDEPEND for Perl's pod2man. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0-r2.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0-r2.ebuild b/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0-r2.ebuild
index 776d3a822186..787f1c49d693 100644
--- a/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0-r2.ebuild
+++ b/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0-r2.ebuild
@@ -13,7 +13,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND="dev-lang/perl"
+BDEPEND="dev-lang/perl"
APACHE2_MOD_CONF="10_${PN}"
APACHE2_MOD_DEFINE="AUTH_TKT"
@@ -36,7 +36,7 @@ pkg_setup() {
}
src_configure() {
- ./configure --apachever=2.2 --apxs=${APXS}
+ ./configure --apachever=2.2 --apxs=${APXS} || die
}
src_compile() {
@@ -45,7 +45,8 @@ src_compile() {
src_install() {
apache-module_src_install
- pod2man --section=5 --release=${PV} doc/${PN}.{pod,5}
+
+ pod2man --section=5 --release=${PV} doc/${PN}.{pod,5} || die
doman doc/${PN}.5
}