summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-01-30 09:23:58 -0500
committerCraig Andrews <candrews@gentoo.org>2023-01-30 09:24:26 -0500
commitf2e012c492e525a92e739669f7e97ee910ac876a (patch)
treefb445467101f8746720270b05cfd90f785de44be /www-apache
parentwww-apps/moodle: bump to 3.11.12, 4.0.6 (diff)
downloadgentoo-f2e012c492e525a92e739669f7e97ee910ac876a.tar.gz
gentoo-f2e012c492e525a92e739669f7e97ee910ac876a.tar.bz2
gentoo-f2e012c492e525a92e739669f7e97ee910ac876a.zip
www-apache/mod_h2: add 2.0.12
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-2.0.12.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index 0eec95862784..8576b0f5a991 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1 +1,2 @@
DIST mod_h2-2.0.11.tar.gz 681879 BLAKE2B e49de5c117c61fc462d6556602f6f975f61754feba6b33f331f391612d8bd447cf2ee8f546e6a5cc6dd766daee0b6678865fbf3e3ed5d670bf67008d14d337ad SHA512 b0dd3ac8e179b78141b2c523a79d9d790588b13988b853a91d99f0f30e4fe0207e17b7dd333d178450ddf4784dedd0fb88d3fd46b96272aa8af6ac7a38fb8d00
+DIST mod_h2-2.0.12.tar.gz 790232 BLAKE2B da06e41b95e5dae0b9e114e749ef07383c565d3decf26a87d939a8377f7f687d03c7e8bac46b5c3ed85f0e0e0dfe9d4eb03548910c10268042878780981aaca7 SHA512 36c07357cfe3896237fb94e09d6a1f131cfa11de7d7e0fa86aac22197836a988daf200978b0b1541712ad990391418b394266871b86817d45597f4a83f7eddfb
diff --git a/www-apache/mod_h2/mod_h2-2.0.12.ebuild b/www-apache/mod_h2/mod_h2-2.0.12.ebuild
new file mode 100644
index 000000000000..5ba43634b8e0
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-2.0.12.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.48[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}