summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-04-14 21:51:05 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-04-14 21:51:25 +0200
commitff5b5674327a2ebe6f21e213f1520c018571005b (patch)
tree66fb8315c3e3a2caef40f8b770a896ebf9cf2b62 /www-apache
parentmedia-libs/vulkan-loader: Require X if building demos (diff)
downloadgentoo-ff5b5674327a2ebe6f21e213f1520c018571005b.tar.gz
gentoo-ff5b5674327a2ebe6f21e213f1520c018571005b.tar.bz2
gentoo-ff5b5674327a2ebe6f21e213f1520c018571005b.zip
www-apache/mod_gnutls: Bump to version 0.8.4
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_gnutls/Manifest1
-rw-r--r--www-apache/mod_gnutls/mod_gnutls-0.8.4.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/www-apache/mod_gnutls/Manifest b/www-apache/mod_gnutls/Manifest
index 882ce1ff3c16..8ab840cea113 100644
--- a/www-apache/mod_gnutls/Manifest
+++ b/www-apache/mod_gnutls/Manifest
@@ -1,2 +1,3 @@
DIST mod_gnutls-0.8.2.tar.bz2 415903 BLAKE2B 98c96479e2419ee511ba802c99823ddaae89ddeb7a2f0660b91e2a371f8249ec4f98b2c0443389168a22dbe133b0bcc6020bfa597447507a8e4f91827b6d1d24 SHA512 b1690aeee4f6d104e4b6a7bd443e289204630b33e00b7b145b11291d8819b5c3d5bd52b535746b8ebdfee7a5f34df527243b743b8c5d716b1d0617e319d43f4d
DIST mod_gnutls-0.8.3.tar.bz2 420257 BLAKE2B a183d11c320e536caef897023d1873bb89f72f7e8e078a5c71f9bdae06ca2c33a03ab68af809ef212757002d91275a537f309eb67fc9cfae8b8880edd75b44a0 SHA512 a0c5babeef5b76e9a10642b3825832290dce3b094d236dd06f76228ba7523ba14c2ada4d97d9c47bf9da0cb0808a9c8fb1080122d27399f6a9267ee0f3ce4656
+DIST mod_gnutls-0.8.4.tar.bz2 422811 BLAKE2B 33b992cbd42671ce0be320268f2421f167c05e62074ad538c22efc1f8b2f1a8604550f103bab579f1dc8622a78bda9e1e62826db06ff0dae21fb9dc1c2ee2bc2 SHA512 cee592f12a26894dacd6db6f25d4b1b1901579ac5cc7dee2be826aa3697bc2af55e2136ef65acd6dc4c9fac635465fbf8c06ea236651d45a2b5fd963408e6684
diff --git a/www-apache/mod_gnutls/mod_gnutls-0.8.4.ebuild b/www-apache/mod_gnutls/mod_gnutls-0.8.4.ebuild
new file mode 100644
index 000000000000..1d6985d4f075
--- /dev/null
+++ b/www-apache/mod_gnutls/mod_gnutls-0.8.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# WARNING! Don't switch to EAPI-6 without checking paths of installed files
+# carefully. The .so file might get installed into /
+EAPI=5
+inherit autotools apache-module
+
+DESCRIPTION="mod_gnutls uses GnuTLS for SSL/TLS encryption in Apache2 (compare to mod_ssl)"
+HOMEPAGE="https://mod.gnutls.org/"
+SRC_URI="https://mod.gnutls.org/downloads/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND=">=net-libs/gnutls-3.3.0:="
+DEPEND="${CDEPEND}
+ test? ( app-crypt/monkeysphere )"
+RDEPEND="${CDEPEND}"
+
+# Fails because gpg-agent cannot be accessed
+RESTRICT="test"
+
+APACHE2_MOD_CONF="47_${PN}"
+APACHE2_MOD_DEFINE="GNUTLS"
+
+DOCFILES="CHANGELOG NOTICE README"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-apxs="${APXS}"
+ --disable-strict
+ --disable-doxygen-dot
+ --disable-doxygen-doc
+ --disable-doxygen-html
+ --disable-doxygen-pdf
+ ac_cv_path_UNSHARE=no
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ apache-module_src_install
+}