summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/blazeblogger
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/blazeblogger')
-rw-r--r--www-apps/blazeblogger/Manifest2
-rw-r--r--www-apps/blazeblogger/blazeblogger-1.2.0-r1.ebuild35
-rw-r--r--www-apps/blazeblogger/blazeblogger-1.2.0.ebuild30
-rw-r--r--www-apps/blazeblogger/files/blazeblogger-1.2.0-bash-completion.patch83
-rw-r--r--www-apps/blazeblogger/metadata.xml11
5 files changed, 161 insertions, 0 deletions
diff --git a/www-apps/blazeblogger/Manifest b/www-apps/blazeblogger/Manifest
new file mode 100644
index 000000000000..5b1aa2d0c314
--- /dev/null
+++ b/www-apps/blazeblogger/Manifest
@@ -0,0 +1,2 @@
+DIST blazeblogger-1.2.0.tar.gz 81340 SHA256 39024b70708be6073e8aeb3943eb3b73d441fbb7b8113e145c0cf7540c4921aa
+DIST blazeblogger-doc-1.2.0.tar.gz 191467 SHA256 a1591f88b245114dea421268f0c4938f1c1a7fa0ba94316f886e0014e20736bc
diff --git a/www-apps/blazeblogger/blazeblogger-1.2.0-r1.ebuild b/www-apps/blazeblogger/blazeblogger-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..d141fe2920d7
--- /dev/null
+++ b/www-apps/blazeblogger/blazeblogger-1.2.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="simple-to-use, capable content management system for the cmdline producing static content"
+HOMEPAGE="http://blaze.blackened.cz/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz
+ doc? ( http://${PN}.googlecode.com/files/${PN}-doc-${PV}.tar.gz ) "
+
+LICENSE="FDL-1.3 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -e '/-m 644 COPYING/d' \
+ -e '/-m 644 INSTALL/d' \
+ -i Makefile || die
+
+ epatch "${FILESDIR}"/${P}-bash-completion.patch #bug 417953
+}
+
+src_install() {
+ emake prefix="${D}/usr" config="${D}/etc" \
+ compdir="${D}/usr/share/bash-completion" install
+
+ use doc && dohtml -r "${WORKDIR}"/${PN}-doc-${PV}/*
+}
diff --git a/www-apps/blazeblogger/blazeblogger-1.2.0.ebuild b/www-apps/blazeblogger/blazeblogger-1.2.0.ebuild
new file mode 100644
index 000000000000..a712acde9fc3
--- /dev/null
+++ b/www-apps/blazeblogger/blazeblogger-1.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="simple-to-use, capable content management system for the cmdline producing static content"
+HOMEPAGE="http://blaze.blackened.cz/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz
+ doc? ( http://${PN}.googlecode.com/files/${PN}-doc-${PV}.tar.gz ) "
+
+LICENSE="FDL-1.3 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -e '/-m 644 COPYING/d' \
+ -e '/-m 644 INSTALL/d' \
+ -i Makefile || die
+}
+
+src_install() {
+ emake prefix="${D}/usr" config="${D}/etc" install
+
+ use doc && dohtml -r "${WORKDIR}"/${PN}-doc-${PV}/*
+}
diff --git a/www-apps/blazeblogger/files/blazeblogger-1.2.0-bash-completion.patch b/www-apps/blazeblogger/files/blazeblogger-1.2.0-bash-completion.patch
new file mode 100644
index 000000000000..8c13ed8086fb
--- /dev/null
+++ b/www-apps/blazeblogger/files/blazeblogger-1.2.0-bash-completion.patch
@@ -0,0 +1,83 @@
+--- blazeblogger-1.2.0/unix/bash_completion
++++ blazeblogger-1.2.0/unix/bash_completion
+@@ -103,7 +103,7 @@
+ # argument completions
+ case "$prev" in
+ -b|--blogdir)
+- COMPREPLY=( $(compgen -d -- ${cur}) )
++ _filedir -d
+ return 0
+ ;;
+ *)
+@@ -131,7 +131,7 @@
+ # argument completions
+ case "$prev" in
+ -b|--blogdir)
+- COMPREPLY=( $(compgen -d -- ${cur}) )
++ _filedir -d
+ return 0
+ ;;
+ -E|--editor)
+@@ -166,7 +166,7 @@
+ # argument completions
+ case "$prev" in
+ -b|--blogdir)
+- COMPREPLY=( $(compgen -d -- ${cur}) )
++ _filedir -d
+ return 0
+ ;;
+ -d|--date)
+@@ -187,7 +187,7 @@
+ COMPREPLY=( $(compgen -W "${specopts}" -- ${cur}) )
+ return 0
+ else
+- COMPREPLY=( $(compgen -f -- ${cur}) )
++ _filedir
+ return 0
+ fi
+ ;;
+@@ -200,7 +200,7 @@
+ # argument completions
+ case "$prev" in
+ -b|--blogdir)
+- COMPREPLY=( $(compgen -d -- ${cur}) )
++ _filedir -d
+ return 0
+ ;;
+ -E|--editor)
+@@ -227,7 +227,7 @@
+ # argument completions
+ case "$prev" in
+ -b|--blogdir)
+- COMPREPLY=( $(compgen -d -- ${cur}) )
++ _filedir -d
+ return 0
+ ;;
+ *)
+@@ -252,7 +252,7 @@
+ # argument completions
+ case "$prev" in
+ -b|--blogdir)
+- COMPREPLY=( $(compgen -d -- ${cur}) )
++ _filedir -d
+ return 0
+ ;;
+ -d|--day)
+@@ -292,7 +292,7 @@
+ # argument completions
+ case "$prev" in
+ -b|--blogdir|-d|--destdir)
+- COMPREPLY=( $(compgen -d -- ${cur}) )
++ _filedir -d
+ return 0
+ ;;
+ *)
+@@ -315,7 +315,7 @@
+ # argument completions
+ case "$prev" in
+ -b|--blogdir)
+- COMPREPLY=( $(compgen -d -- ${cur}) )
++ _filedir -d
+ return 0
+ ;;
+ -n|--number)
diff --git a/www-apps/blazeblogger/metadata.xml b/www-apps/blazeblogger/metadata.xml
new file mode 100644
index 000000000000..27aeb4d46934
--- /dev/null
+++ b/www-apps/blazeblogger/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">blazeblogger</remote-id>
+ </upstream>
+</pkgmetadata>