summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTill Schäfer <till2.schaefer@uni-dortmund.de>2019-09-26 21:41:26 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-10-01 08:07:16 +0300
commit13f9c7650574042d734591b91cd3134652cbe0f7 (patch)
treef38a4e49b65e7b21f6482e51f71f91eb64cb1d6d /www-apps/davical
parentdev-php/awl: bump to 0.60 (diff)
downloadgentoo-13f9c7650574042d734591b91cd3134652cbe0f7.tar.gz
gentoo-13f9c7650574042d734591b91cd3134652cbe0f7.tar.bz2
gentoo-13f9c7650574042d734591b91cd3134652cbe0f7.zip
www-apps/davical: bump to 1.1.8
upgrade to EAPI 7 corrected dependencies add proper upgrade message add ldap use flag fix license backport changes to 1.1.7-r2 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Till Schäfer <till2.schaefer@uni-dortmund.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-apps/davical')
-rw-r--r--www-apps/davical/Manifest1
-rw-r--r--www-apps/davical/davical-1.1.7-r2.ebuild72
-rw-r--r--www-apps/davical/davical-1.1.8.ebuild70
-rw-r--r--www-apps/davical/files/postinstall-en.txt15
-rw-r--r--www-apps/davical/files/postupgrade-en.txt4
5 files changed, 148 insertions, 14 deletions
diff --git a/www-apps/davical/Manifest b/www-apps/davical/Manifest
index 5e6249b3a8e8..b6ad08ca438b 100644
--- a/www-apps/davical/Manifest
+++ b/www-apps/davical/Manifest
@@ -1 +1,2 @@
DIST davical-1.1.7.tar.xz 1347368 BLAKE2B 74418e99190db94dbb95fe9bdbed8f468cf98070a6ef86cb5af1f6460a97eb8c2faede7858a38b9728c5b3e400c6340f1abf3f00ae757847d8996b22e709f70e SHA512 d66388479259a8369f3a648a9d81f1e2f5488f6a3c4415360c133b21b6c6d4b4d433d5f94a635cffdaa0385a56c24176fa660ee8653d75246604655ccdd1a455
+DIST davical-1.1.8.tar.xz 1358060 BLAKE2B 9b38081981e876bfdb025bfb5cbd57843645e399df0816658c395ab8c2447809930596a4adcc7bb30f357435735a435c75b03431505eec24fd5adb270845fc39 SHA512 e4a81a80086cdb67af47202865ad1652e83f276d2b82fc80b8bff60682027c911f2000052b1f32008269c77147462ec21886eae78fb3b5d4247b747fb9c4d1e6
diff --git a/www-apps/davical/davical-1.1.7-r2.ebuild b/www-apps/davical/davical-1.1.7-r2.ebuild
new file mode 100644
index 000000000000..9d2ef12cb2f7
--- /dev/null
+++ b/www-apps/davical/davical-1.1.7-r2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+DESCRIPTION="A CalDAV and CardDAV Server"
+HOMEPAGE="https://www.davical.org/"
+SRC_URI="https://www.davical.org/downloads/${PN}_${PV}.orig.tar.xz -> ${P}.tar.xz"
+
+LICENSE="GPL-2 GPL-2+ GPL-3+ LGPL-2.1+ LGPL-3+"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap"
+
+BDEPEND="sys-devel/gettext"
+
+RDEPEND="app-admin/pwgen
+ dev-lang/php:*[calendar,curl,iconv,imap,ldap?,nls,pdo,postgres,xml]
+ dev-perl/DBD-Pg
+ dev-perl/DBI
+ dev-perl/YAML
+ >=dev-php/awl-0.59
+ virtual/httpd-php"
+
+need_httpd
+
+PATCHES=( "${FILESDIR}/${P}-fix_php4_style_constructors.patch" )
+
+S="${WORKDIR}"
+
+src_compile() {
+ emake built-locale
+}
+
+src_install() {
+ webapp_src_preinst
+
+ einstalldocs
+
+ einfo "Installing web files"
+ insinto "${MY_HTDOCSDIR}"
+ doins -r htdocs/. htdocs/.htaccess
+
+ einfo "Installing main files and i18n"
+ insinto "${MY_HOSTROOTDIR}/${PN}"
+ doins -r inc locale
+ rm "${ED}/${MY_HOSTROOTDIR}/${PN}/inc/always.php.in" || die
+
+ einfo "Installing sql files"
+ insinto "${MY_SQLSCRIPTSDIR}"
+ doins -r dba/.
+
+ insinto /etc/${PN}
+ doins -r config/. "${FILESDIR}/vhost-example"
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+ webapp_postupgrade_txt en "${FILESDIR}/postupgrade-en.txt"
+ webapp_src_install
+
+ fperms +x "${MY_SQLSCRIPTSDIR}/create-database.sh"
+ fperms +x "${MY_SQLSCRIPTSDIR}/update-davical-database"
+}
+
+pkg_postinst() {
+ elog "If you are upgrading from a previous version of davical, don't forget to"
+ elog "upgrade the database structure with"
+ elog " cd /usr/share/webapps/davical/${PVR}/sqlscripts/"
+ elog " ./update-davical-database -dbuser xxxxxxx -appuser xxxxxx"
+
+ webapp_pkg_postinst
+}
diff --git a/www-apps/davical/davical-1.1.8.ebuild b/www-apps/davical/davical-1.1.8.ebuild
new file mode 100644
index 000000000000..b7cc044e06db
--- /dev/null
+++ b/www-apps/davical/davical-1.1.8.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+DESCRIPTION="A CalDAV and CardDAV Server"
+HOMEPAGE="https://www.davical.org/"
+SRC_URI="https://www.davical.org/downloads/${PN}_${PV}.orig.tar.xz -> ${P}.tar.xz"
+
+LICENSE="GPL-2 GPL-2+ GPL-3+ LGPL-2.1+ LGPL-3+"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap"
+
+BDEPEND="sys-devel/gettext"
+
+RDEPEND="app-admin/pwgen
+ dev-lang/php:*[calendar,curl,iconv,imap,ldap?,nls,pdo,postgres,xml]
+ dev-perl/DBD-Pg
+ dev-perl/DBI
+ dev-perl/YAML
+ >=dev-php/awl-0.60
+ virtual/httpd-php"
+
+need_httpd
+
+S="${WORKDIR}"
+
+src_compile() {
+ emake built-locale
+}
+
+src_install() {
+ webapp_src_preinst
+
+ einstalldocs
+
+ einfo "Installing web files"
+ insinto "${MY_HTDOCSDIR}"
+ doins -r htdocs/. htdocs/.htaccess
+
+ einfo "Installing main files and i18n"
+ insinto "${MY_HOSTROOTDIR}/${PN}"
+ doins -r inc locale
+ rm "${ED}/${MY_HOSTROOTDIR}/${PN}/inc/always.php.in" || die
+
+ einfo "Installing sql files"
+ insinto "${MY_SQLSCRIPTSDIR}"
+ doins -r dba/.
+
+ insinto /etc/${PN}
+ doins -r config/. "${FILESDIR}/vhost-example"
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+ webapp_postupgrade_txt en "${FILESDIR}/postupgrade-en.txt"
+ webapp_src_install
+
+ fperms +x "${MY_SQLSCRIPTSDIR}/create-database.sh"
+ fperms +x "${MY_SQLSCRIPTSDIR}/update-davical-database"
+}
+
+pkg_postinst() {
+ elog "If you are upgrading from a previous version of davical, don't forget to"
+ elog "upgrade the database structure with"
+ elog " cd /usr/share/webapps/davical/${PVR}/sqlscripts/"
+ elog " ./update-davical-database -dbuser xxxxxxx -appuser xxxxxx"
+
+ webapp_pkg_postinst
+}
diff --git a/www-apps/davical/files/postinstall-en.txt b/www-apps/davical/files/postinstall-en.txt
index 5a88a2bdf2e4..9a6192c15510 100644
--- a/www-apps/davical/files/postinstall-en.txt
+++ b/www-apps/davical/files/postinstall-en.txt
@@ -2,17 +2,4 @@ You will need access to postgresql database to use davical.
Read /usr/share/doc/www-apps/davical-${PVR}/INSTALL.gz for installation
instructions.
-Release notes are available at
-http://wiki.davical.org/w/Release_Notes/${PVR}.
-Full documentation and wiki on http://davical.org
-
-If you are upgrading from a previous version of davical, don't forget to
-upgrade the database structure with
- cd /usr/share/webapps/davical/${PVR}/sqlscripts/
- ./update-davical-database -dbuser xxxxxxx -appuser xxxxxx
-
-You can safely ignore any message about missing time_zone table.
-
-If you are upgrading from a version <= 0.9.8.4 please note inc/ and locale/
-have been moved away from the htdocs directory and placed into hostroot for
-safety reasons.
+Full documentation and wiki on http://www.davical.org
diff --git a/www-apps/davical/files/postupgrade-en.txt b/www-apps/davical/files/postupgrade-en.txt
new file mode 100644
index 000000000000..51b86e2c4122
--- /dev/null
+++ b/www-apps/davical/files/postupgrade-en.txt
@@ -0,0 +1,4 @@
+If you are upgrading from a previous version of davical, don't forget to
+upgrade the database structure with
+ cd /usr/share/webapps/davical/${PVR}/sqlscripts/
+ ./update-davical-database -dbuser xxxxxxx -appuser xxxxxx