summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2018-09-12 15:13:46 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2018-09-12 15:15:33 +0300
commitff8ccfa19cfe0c7fb0cd3e8afd13c3f1b33c00ef (patch)
treec4617e924a8e43f0011b4a7186c7debbfc8ed869 /www-apps/drupal
parentdev-python/django-pipeline: remove last-rited package (diff)
downloadgentoo-ff8ccfa19cfe0c7fb0cd3e8afd13c3f1b33c00ef.tar.gz
gentoo-ff8ccfa19cfe0c7fb0cd3e8afd13c3f1b33c00ef.tar.bz2
gentoo-ff8ccfa19cfe0c7fb0cd3e8afd13c3f1b33c00ef.zip
www-apps/drupal: Version bump
Package-Manager: Portage-2.3.47, Repoman-2.3.10
Diffstat (limited to 'www-apps/drupal')
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-8.6.1.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index c7322b66b029..00426d53c71f 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,2 +1,3 @@
DIST drupal-7.59.tar.gz 3282260 BLAKE2B bf7d74926fe4e94149ef7ff622cf7889f45f3e35b9bfd19fed12aa688c8131f2f8daa2a261796896d5386966603e837b6dec3b6c02221f9b0c527c4a6f5ff9da SHA512 68f02b39d1a4658adc0f0046c22cc1059b68f952f9cd753f5a3e379cf93705be308b4727519e90d77a42437442daebaa78d76745954be4d40e1a5105c319069c
DIST drupal-8.6.0.tar.gz 16233161 BLAKE2B ad7a1eb65555b37799bb30aa7364c413bc8edb2a12eeee2e82beb78b40ac041123964b5eae68fc28340e965a061bd3337ad2b01e23c00af0f91338838926c6a0 SHA512 ed94168bf3eb8dca506b8da4d9607c40ed4b2d588a683d3316d16c51d919300a506f596880aba2cd2aab19649b2c18c2843f4bae93b33b4f08e93d013a2c5e64
+DIST drupal-8.6.1.tar.gz 16236559 BLAKE2B 6c7b2d396b285290e0ef537777054cfe1d50b6188d3400bb0f0c6c35f3ae677b6d7f9ba53e28f95c4a89aeadd2dc7fc1b7c659048332a21d0ffc543bf8c4df41 SHA512 f42eab1f7110219d11f398c5099cd0abf50883819fbe6a879d08f1117e3cc413937772a269d28ffe09ba59b24f79516d03601ccfd2abfb37ed18064f34368b5a
diff --git a/www-apps/drupal/drupal-8.6.1.ebuild b/www-apps/drupal/drupal-8.6.1.ebuild
new file mode 100644
index 000000000000..ec2dacba2d14
--- /dev/null
+++ b/www-apps/drupal/drupal-8.6.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}