summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2021-06-03 09:11:55 +0200
committerSam James <sam@gentoo.org>2021-06-21 23:30:02 +0100
commit0226cb38b5d333022568ee6db0ece783bce678f9 (patch)
treefd7509b14a02c0fcc50485513b8bc348506dcff0 /www-apps/gitea
parentwww-apps/gitea: bump to 1.14.2 (diff)
downloadgentoo-0226cb38b5d333022568ee6db0ece783bce678f9.tar.gz
gentoo-0226cb38b5d333022568ee6db0ece783bce678f9.tar.bz2
gentoo-0226cb38b5d333022568ee6db0ece783bce678f9.zip
www-apps/gitea: drop old
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Pierre-Olivier Mercier <nemunaire@nemunai.re> Closes: https://github.com/gentoo/gentoo/pull/21099 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apps/gitea')
-rw-r--r--www-apps/gitea/Manifest1
-rw-r--r--www-apps/gitea/files/gitea.service-r234
-rw-r--r--www-apps/gitea/gitea-1.13.7.ebuild129
3 files changed, 0 insertions, 164 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index 719f20e2bf5c..56b6dfcf5f48 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -1,2 +1 @@
-DIST gitea-1.13.7.tar.gz 151035143 BLAKE2B 349018a127337251d55e8681c6c509e195905b978711f60a031b5cb55c1cc6fe5c1312eaef6c3343c3a963b748adf3ef88b6b35176279f517c946f74532f2fcd SHA512 018948d4d40f41c01bc8d9fd74b1d170a8cd7a82402913ee1d11dc283a4946971f76356640213d79877160c29b58b9c393a7d761da695545939db50a3f137f7e
DIST gitea-1.14.2.tar.gz 117884130 BLAKE2B 75ae36ade602bcbdcc59cd3f75f60ab5fbde713399b1d8b83f29b2bee044c9a5dc83fbae8f372f62c991edeef7237a5a96a9f6b4cda0ae1db93d6596377e1a98 SHA512 073ff6d718522c1b8d2746379d6d0051dd18db89331604c1cc252bcedbad04e75a1f402bdd37fea05d21e6b5d24f43ebf9e70748f8522996fdf8eb133d2a3e38
diff --git a/www-apps/gitea/files/gitea.service-r2 b/www-apps/gitea/files/gitea.service-r2
deleted file mode 100644
index 1931b46c73c4..000000000000
--- a/www-apps/gitea/files/gitea.service-r2
+++ /dev/null
@@ -1,34 +0,0 @@
-[Unit]
-Description=Gitea service
-Documentation=https://docs.gitea.io/
-
-AssertPathIsDirectory=/var/lib/gitea
-AssertPathIsReadWrite=/var/lib/gitea
-
-After=network.target
-Requires=network.target
-After=mysqld.service
-After=postgresql-9.3.service
-After=postgresql-9.4.service
-After=postgresql-9.5.service
-After=postgresql-9.6.service
-After=postgresql-10.service
-After=postgresql-11.service
-After=postgresql-12.service
-After=memcached.service
-After=redis.service
-
-[Service]
-User=git
-Group=git
-
-Environment="GITEA_WORK_DIR=/var/lib/gitea" "GITEA_CUSTOM=/var/lib/gitea/custom"
-WorkingDirectory=/var/lib/gitea
-ExecStart=/usr/bin/gitea web --config /etc/gitea/app.ini
-
-Restart=always
-PrivateTmp=true
-Nice=5
-
-[Install]
-WantedBy=multi-user.target
diff --git a/www-apps/gitea/gitea-1.13.7.ebuild b/www-apps/gitea/gitea-1.13.7.ebuild
deleted file mode 100644
index a68755728ea8..000000000000
--- a/www-apps/gitea/gitea-1.13.7.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit fcaps go-module tmpfiles systemd
-MY_PV="${PV/_rc/-rc}"
-
-DESCRIPTION="A painless self-hosted Git service"
-HOMEPAGE="https://gitea.io"
-
-if [[ ${PV} != 9999* ]] ; then
- SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${MY_PV}/gitea-src-${MY_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64"
- S="${WORKDIR}"
-else
- EGIT_REPO_URI="https://github.com/go-gitea/gitea"
- inherit git-r3
- S="${WORKDIR}/${P}"
-fi
-
-LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
-SLOT="0"
-IUSE="+acct build-client pam sqlite"
-
-BDEPEND="build-client? ( >=net-libs/nodejs-10[npm] )"
-COMMON_DEPEND="
- acct? (
- acct-group/git
- acct-user/git[gitea] )
- pam? ( sys-libs/pam )"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}
- dev-vcs/git"
-
-DOCS=(
- custom/conf/app.example.ini CONTRIBUTING.md README.md
-)
-FILECAPS=(
- cap_net_bind_service+ep usr/bin/gitea
-)
-
-RESTRICT="test"
-QA_PRESTRIPPED="usr/bin/gitea"
-
-src_prepare() {
- default
-
- local sedcmds=(
- -e "s#^ROOT =#ROOT = ${EPREFIX}/var/lib/gitea/gitea-repositories#"
- -e "s#^ROOT_PATH =#ROOT_PATH = ${EPREFIX}/var/log/gitea#"
- -e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${EPREFIX}/var/lib/gitea/data#"
- -e "s#^HTTP_ADDR = 0.0.0.0#HTTP_ADDR = 127.0.0.1#"
- -e "s#^MODE = console#MODE = file#"
- -e "s#^LEVEL = Trace#LEVEL = Info#"
- -e "s#^LOG_SQL = true#LOG_SQL = false#"
- -e "s#^DISABLE_ROUTER_LOG = false#DISABLE_ROUTER_LOG = true#"
- )
-
- sed -i "${sedcmds[@]}" custom/conf/app.example.ini || die
- if use sqlite ; then
- sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.example.ini || die
- fi
-
- einfo "Remove tests which are known to fail with network-sandbox enabled."
- rm ./modules/migrations/github_test.go || die
-
- einfo "Remove tests which depend on gitea git-repo."
- rm ./modules/git/blob_test.go || die
- rm ./modules/git/repo_test.go || die
-
- # Remove already build assets (like frontend part)
- use build-client && emake clean-all
-}
-
-src_compile() {
- local gitea_tags=(
- bindata
- $(usev pam)
- $(usex sqlite 'sqlite sqlite_unlock_notify' '')
- )
- local gitea_settings=(
- "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/gitea/app.ini"
- "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
- "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
- )
- local makeenv=(
- TAGS="${gitea_tags[*]}"
- LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[*]}"
- )
- [[ ${PV} != 9999* ]] && makeenv+=("DRONE_TAG=${MY_PV}")
-
- if use build-client; then
- # -j1 as Makefile doesn't handle dependancy correctly, and is not
- # useful as golang compiler don't use this info.
- env "${makeenv[@]}" emake -j1 build
- else
- env "${makeenv[@]}" emake backend
- fi
-}
-
-src_install() {
- dobin gitea
-
- einstalldocs
-
- newconfd "${FILESDIR}/gitea.confd-r1" gitea
- newinitd "${FILESDIR}/gitea.initd-r3" gitea
- newtmpfiles - gitea.conf <<-EOF
- d /run/gitea 0755 git git
- EOF
- systemd_newunit "${FILESDIR}"/gitea.service-r2 gitea.service
-
- insinto /etc/gitea
- newins custom/conf/app.example.ini app.ini
- if use acct ; then
- fowners root:git /etc/gitea/{,app.ini}
- fperms g+w,o-rwx /etc/gitea/{,app.ini}
-
- diropts -m0750 -o git -g git
- keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
- keepdir /var/log/gitea
- fi
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
- go-module_pkg_postinst
- tmpfiles_process gitea.conf
-}