summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-12-01 17:54:25 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-12-01 17:54:52 +0200
commit63d70212888254daff66584c4fab5613bfaa2966 (patch)
tree25346657a52b0d883383c312a893c7233a834276 /www-apps/gitea
parentapp-text/coolreader: add subslot operator for libunibreak (diff)
downloadgentoo-63d70212888254daff66584c4fab5613bfaa2966.tar.gz
gentoo-63d70212888254daff66584c4fab5613bfaa2966.tar.bz2
gentoo-63d70212888254daff66584c4fab5613bfaa2966.zip
www-apps/gitea: sync -9999 ebuild
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-apps/gitea')
-rw-r--r--www-apps/gitea/gitea-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/www-apps/gitea/gitea-9999.ebuild b/www-apps/gitea/gitea-9999.ebuild
index a5eec77f6034..4da3155a2589 100644
--- a/www-apps/gitea/gitea-9999.ebuild
+++ b/www-apps/gitea/gitea-9999.ebuild
@@ -2,11 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit fcaps go-module tmpfiles systemd
MY_PV="${PV/_rc/-rc}"
DESCRIPTION="A painless self-hosted Git service"
-HOMEPAGE="https://gitea.io"
+HOMEPAGE="https://gitea.io https://github.com/go-gitea/gitea"
if [[ ${PV} != 9999* ]] ; then
SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${MY_PV}/gitea-src-${MY_PV}.tar.gz -> ${P}.tar.gz"
@@ -22,13 +23,12 @@ LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
SLOT="0"
IUSE="+acct pam sqlite"
-COMMON_DEPEND="
+DEPEND="
acct? (
acct-group/git
acct-user/git[gitea] )
pam? ( sys-libs/pam )"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}
+RDEPEND="${DEPEND}
dev-vcs/git"
DOCS=(