summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/kibana-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/kibana-bin')
-rw-r--r--www-apps/kibana-bin/Manifest2
-rw-r--r--www-apps/kibana-bin/files/kibana.initd39
-rw-r--r--www-apps/kibana-bin/files/kibana.initd-r118
-rw-r--r--www-apps/kibana-bin/kibana-bin-4.0.3.ebuild39
-rw-r--r--www-apps/kibana-bin/kibana-bin-4.1.1.ebuild39
-rw-r--r--www-apps/kibana-bin/metadata.xml12
6 files changed, 149 insertions, 0 deletions
diff --git a/www-apps/kibana-bin/Manifest b/www-apps/kibana-bin/Manifest
new file mode 100644
index 000000000000..e94bca76b59b
--- /dev/null
+++ b/www-apps/kibana-bin/Manifest
@@ -0,0 +1,2 @@
+DIST kibana-4.0.3-linux-x64.tar.gz 14331227 SHA256 320a43ed11f8f3f95709ceaec11ef8192c9bc2e64ea73a5f973b43aa8a422922 SHA512 745faffd9d8d67d6322f64223b829eb8eff4fba5d2f435a72b0c52c64e1578f0f5e741285c20904b6215d0c8da2cc5833fead86fc519bb4fdc51e8d51a18c465 WHIRLPOOL 2e67b9ba702ff78b9e775517333739cb96ad7dc88ab413768b897374f5ec25daa3b861f420b54451906231eca0ce5558306613a6597a7c85d340d897da0a0a08
+DIST kibana-4.1.1-linux-x64.tar.gz 11676499 SHA256 6f42d25f337fd49f38e2af81b9ab6e0c987a199a8c0b2e1410d072f812cb4520 SHA512 d72f235704e2a85b4d993f55550b5d8b6de049f05f4ff7781e122af65fca88d3966db188a8bbc877928751aacd69f8ecf4c412cd05bfa88d1a9e785fa952aeed WHIRLPOOL a60321cf7ae511dd03c2099b61ea0fe5abb479b264842150a84d6791e8b9ba6682dc1c95059800a8cf714898350ec533440eb43240fa78491836fa3b7d6ef23d
diff --git a/www-apps/kibana-bin/files/kibana.initd b/www-apps/kibana-bin/files/kibana.initd
new file mode 100644
index 000000000000..9effc545218e
--- /dev/null
+++ b/www-apps/kibana-bin/files/kibana.initd
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+command="/opt/kibana/bin/kibana"
+pidfile="/run/kibana.pid"
+KIBANA_USER=${KIBANA_USER:="kibana"}
+
+depend() {
+ need elasticsearch
+}
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+
+ checkpath -d -o "${KIBANA_USER}" -m750 "/var/log/kibana"
+
+ start-stop-daemon --start \
+ --user $KIBANA_USER \
+ --background \
+ --make-pidfile \
+ --pidfile $pidfile \
+ --stdout /var/log/kibana/kibana.log \
+ --stderr /var/log/kibana/kibana.err \
+ --exec $command
+
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+
+ start-stop-daemon --stop \
+ --pidfile $pidfile
+
+
+ eend $?
+}
diff --git a/www-apps/kibana-bin/files/kibana.initd-r1 b/www-apps/kibana-bin/files/kibana.initd-r1
new file mode 100644
index 000000000000..3fdcec648c8e
--- /dev/null
+++ b/www-apps/kibana-bin/files/kibana.initd-r1
@@ -0,0 +1,18 @@
+#!/sbin/openrc-run
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+KIBANA_USER=${KIBANA_USER:-kibana}
+
+command="/opt/kibana/bin/kibana"
+pidfile="/run/kibana.pid"
+command_background="true"
+start_stop_daemon_args="--user=\"${KIBANA_USER}\" --stdout /var/log/kibana/kibana.log --stderr /var/log/kibana/kibana.err"
+
+depend() {
+ need elasticsearch
+}
+
+start_pre() {
+ checkpath -d -o "${KIBANA_USER}" -m750 "/var/log/kibana"
+}
diff --git a/www-apps/kibana-bin/kibana-bin-4.0.3.ebuild b/www-apps/kibana-bin/kibana-bin-4.0.3.ebuild
new file mode 100644
index 000000000000..ee1c13e71b72
--- /dev/null
+++ b/www-apps/kibana-bin/kibana-bin-4.0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit user
+
+MY_PN="kibana"
+MY_P=${MY_PN}-${PV/_rc/-rc}
+
+DESCRIPTION="visualize logs and time-stamped data"
+HOMEPAGE="http://www.elasticsearch.org/overview/kibana/"
+SRC_URI="https://download.elasticsearch.org/${MY_PN}/${MY_PN}/${MY_P}-linux-x64.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=app-misc/elasticsearch-1.4.4"
+
+RESTRICT="strip"
+QA_PREBUILT="opt/kibana/node/bin/node"
+
+S="${WORKDIR}/${MY_P}-linux-x64"
+
+pkg_setup() {
+ enewgroup ${MY_PN}
+ enewuser ${MY_PN} -1 -1 /opt/${MY_PN} ${MY_PN}
+}
+
+src_install() {
+ keepdir /opt/${MY_PN}
+ keepdir /var/log/${MY_PN}
+
+ newinitd "${FILESDIR}"/kibana.initd "${MY_PN}"
+
+ mv * "${D}/opt/${MY_PN}"
+}
diff --git a/www-apps/kibana-bin/kibana-bin-4.1.1.ebuild b/www-apps/kibana-bin/kibana-bin-4.1.1.ebuild
new file mode 100644
index 000000000000..4ee1ab1c47ad
--- /dev/null
+++ b/www-apps/kibana-bin/kibana-bin-4.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit user
+
+MY_PN="kibana"
+MY_P=${MY_PN}-${PV/_rc/-rc}
+
+DESCRIPTION="visualize logs and time-stamped data"
+HOMEPAGE="https://www.elastic.co/products/kibana"
+SRC_URI="https://download.elastic.co/${MY_PN}/${MY_PN}/${MY_P}-linux-x64.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=app-misc/elasticsearch-1.4.4"
+
+RESTRICT="strip"
+QA_PREBUILT="opt/kibana/node/bin/node"
+
+S="${WORKDIR}/${MY_P}-linux-x64"
+
+pkg_setup() {
+ enewgroup ${MY_PN}
+ enewuser ${MY_PN} -1 -1 /opt/${MY_PN} ${MY_PN}
+}
+
+src_install() {
+ keepdir /opt/${MY_PN}
+ keepdir /var/log/${MY_PN}
+
+ newinitd "${FILESDIR}"/kibana.initd-r1 "${MY_PN}"
+
+ mv * "${D}/opt/${MY_PN}"
+}
diff --git a/www-apps/kibana-bin/metadata.xml b/www-apps/kibana-bin/metadata.xml
new file mode 100644
index 000000000000..cf1b4281a444
--- /dev/null
+++ b/www-apps/kibana-bin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>hydrapolic@gmail.com</email>
+ <name>Tomas Mozes</name>
+ <description>Proxy maintainer</description>
+ </maintainer>
+</pkgmetadata>