summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-07-11 16:32:11 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-07-11 17:46:07 +0200
commit642af4e790962b53c734e3f967d88a753b1fa655 (patch)
tree4ec2f000d053bc1c67068ee827926a9d0fd523cc /www-apps/kibana-bin
parentwww-apps/kibana-bin: add note about nodejs version (diff)
downloadgentoo-642af4e790962b53c734e3f967d88a753b1fa655.tar.gz
gentoo-642af4e790962b53c734e3f967d88a753b1fa655.tar.bz2
gentoo-642af4e790962b53c734e3f967d88a753b1fa655.zip
www-apps/kibana-bin: bump to 6.3.1
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'www-apps/kibana-bin')
-rw-r--r--www-apps/kibana-bin/Manifest1
-rw-r--r--www-apps/kibana-bin/kibana-bin-6.3.1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/www-apps/kibana-bin/Manifest b/www-apps/kibana-bin/Manifest
index a5041c12cc4c..db9a66eadc28 100644
--- a/www-apps/kibana-bin/Manifest
+++ b/www-apps/kibana-bin/Manifest
@@ -2,3 +2,4 @@ DIST kibana-5.6.10-linux-x86_64.tar.gz 52586941 BLAKE2B cb4e1716c640c80be980541e
DIST kibana-5.6.9-linux-x86_64.tar.gz 52381284 BLAKE2B 962891ada991f718bb3a1445ec369db0e71e27aa76fb0170d57dfa66ea2b3e14289412464ec6c6b687e09fb3cad77a7900985dbcbd7fb29e103b06ba6cc8aa9c SHA512 e30fd6735b5fa510b81ba70a66faf2ff57ea01bcc0b0379607173d7a8cef44628efcaa0bd055b3f6672f7874c616c0d99b353a0e14d354879a9675fd367676fa
DIST kibana-6.2.2-linux-x86_64.tar.gz 83415765 BLAKE2B 86f7511c82b6954a8769673b856eb46f2b633490535a013d4e30138e8abee470776493de43284f2e68b2cac6b74ba2b76245fd35803b8b5834f79ea5f488dd6b SHA512 8d26eb8293028aa0c35942a7b5025401f9b717d5c548d6cdbcf2761c0d8cc1189fdbf12c6f39468d4c809a3975f5f3c817e0f02424b296ce36183e118b0c72c6
DIST kibana-6.2.4-linux-x86_64.tar.gz 85348919 BLAKE2B ce062a5a7d96c0266143f1091f7dbe5ade6236068a73f6fedbe253957f7ddf2d00b441d985f72e9936aa3bfa7ecd9e7b7672b301b726a7d78c3e2b71d52c3b24 SHA512 125c2002e1a3b197f9f0d6200f2979f2e5974a902bfec2baa4b34a0c8d55babccafdb87b8a7b69c61ca4c02b8ae97e69b9b2743f7d445f0e53e31c69288296d5
+DIST kibana-oss-6.3.1-linux-x86_64.tar.gz 89617065 BLAKE2B bdadf0ddecb060d64ed07f4f3f62934b4ae686f00d1dafbe8030acf95431b13049f53ffe7a6f8eb695d9cb1dc45151110f430c1953e1c0e1edd3656819ee0cb8 SHA512 6be02af23878dae1d48b81e8a46704f35a0bc136dd0952d997ba1f00d080868960fc3fc86d37e1e1fad5acb74dc2345e09ccc7d27862575d5783708d058c6831
diff --git a/www-apps/kibana-bin/kibana-bin-6.3.1.ebuild b/www-apps/kibana-bin/kibana-bin-6.3.1.ebuild
new file mode 100644
index 000000000000..964f443c817e
--- /dev/null
+++ b/www-apps/kibana-bin/kibana-bin-6.3.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eapi7-ver systemd user
+
+MY_PN="${PN%-bin}"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Analytics and search dashboard for Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/kibana"
+SRC_URI="https://artifacts.elastic.co/downloads/${MY_PN}/${MY_PN}-oss-${PV}-linux-x86_64.tar.gz"
+
+# source: LICENSE.txt and NOTICE.txt
+LICENSE="Apache-2.0 Artistic-2 BSD BSD-2 CC-BY-3.0 CC-BY-4.0 icu ISC MIT MPL-2.0 OFL-1.1 openssl public-domain Unlicense WTFPL-2 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="net-libs/nodejs"
+
+S="${WORKDIR}/${MY_P}-linux-x86_64"
+
+pkg_setup() {
+ enewgroup ${MY_PN}
+ enewuser ${MY_PN} -1 -1 /opt/${MY_PN} ${MY_PN}
+}
+
+src_prepare() {
+ default
+
+ # remove bundled nodejs
+ rm -r node || die
+
+ # remove empty unused directory
+ rmdir data || die
+}
+
+src_install() {
+ insinto /etc/${MY_PN}
+ doins -r config/.
+ rm -r config || die
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${MY_PN}.logrotate ${MY_PN}
+
+ newconfd "${FILESDIR}"/${MY_PN}.confd ${MY_PN}
+ newinitd "${FILESDIR}"/${MY_PN}.initd ${MY_PN}
+ systemd_dounit "${FILESDIR}"/${MY_PN}.service
+
+ insinto /opt/${MY_PN}
+ doins -r .
+
+ chmod +x "${ED%/}"/opt/${MY_PN}/bin/* || die
+
+ diropts -m 0750 -o ${MY_PN} -g ${MY_PN}
+ keepdir /var/log/${MY_PN}
+}
+
+pkg_postinst() {
+ elog "This version of Kibana is compatible with Elasticsearch $(ver_cut 1-2) and"
+ elog "Node.js 8. Some plugins may fail with other versions of Node.js (Bug #656008)."
+ elog
+ elog "To set a customized Elasticsearch instance:"
+ elog " OpenRC: set ES_INSTANCE in /etc/conf.d/${MY_PN}"
+ elog " systemd: set elasticsearch.url in /etc/${MY_PN}/kibana.yml"
+ elog
+ elog "Elasticsearch can run local or remote."
+}