summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-09-17 12:48:32 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-28 11:44:34 +0200
commit76c7093c8864e6ad1fb37f9959164a637dade5e4 (patch)
treeec4aa1de7ab4b59ce0c6a18167159c9eceb6059d /www-apps/kibana-bin
parentwww-apps/kibana-bin: allow using newer node.js version (diff)
downloadgentoo-76c7093c8864e6ad1fb37f9959164a637dade5e4.tar.gz
gentoo-76c7093c8864e6ad1fb37f9959164a637dade5e4.tar.bz2
gentoo-76c7093c8864e6ad1fb37f9959164a637dade5e4.zip
www-apps/kibana-bin: drop old
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'www-apps/kibana-bin')
-rw-r--r--www-apps/kibana-bin/kibana-bin-6.4.0.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/www-apps/kibana-bin/kibana-bin-6.4.0.ebuild b/www-apps/kibana-bin/kibana-bin-6.4.0.ebuild
deleted file mode 100644
index ad544d11f39b..000000000000
--- a/www-apps/kibana-bin/kibana-bin-6.4.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit systemd user
-
-MY_PN="${PN%-bin}"
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Analytics and search dashboard for Elasticsearch"
-HOMEPAGE="https://www.elastic.co/products/kibana"
-SRC_URI="x-pack? ( https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}-linux-x86_64.tar.gz )
- !x-pack? ( https://artifacts.elastic.co/downloads/${MY_PN}/${MY_PN}-oss-${PV}-linux-x86_64.tar.gz )"
-
-# source: LICENSE.txt and NOTICE.txt
-LICENSE="Apache-2.0 Artistic-2 BSD BSD-2 CC-BY-3.0 CC-BY-4.0 icu ISC MIT MPL-2.0 OFL-1.1 openssl public-domain Unlicense WTFPL-2 ZLIB x-pack? ( Elastic )"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="x-pack"
-
-RDEPEND="net-libs/nodejs"
-
-S="${WORKDIR}/${MY_P}-linux-x86_64"
-
-pkg_setup() {
- enewgroup ${MY_PN}
- enewuser ${MY_PN} -1 -1 /opt/${MY_PN} ${MY_PN}
-}
-
-src_prepare() {
- default
-
- # remove bundled nodejs
- rm -r node || die
-
- # remove empty unused directory
- rmdir data || die
-}
-
-src_install() {
- insinto /etc/${MY_PN}
- doins -r config/.
- rm -r config || die
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/${MY_PN}.logrotate ${MY_PN}
-
- newconfd "${FILESDIR}"/${MY_PN}.confd ${MY_PN}
- newinitd "${FILESDIR}"/${MY_PN}.initd ${MY_PN}
- systemd_dounit "${FILESDIR}"/${MY_PN}.service
-
- insinto /opt/${MY_PN}
- doins -r .
-
- chmod +x "${ED%/}"/opt/${MY_PN}/bin/* || die
-
- diropts -m 0750 -o ${MY_PN} -g ${MY_PN}
- keepdir /var/log/${MY_PN}
-}
-
-pkg_postinst() {
- elog "This version of Kibana is compatible with Elasticsearch $(ver_cut 1-2) and"
- elog "Node.js 8. Some plugins may fail with other versions of Node.js (Bug #656008)."
- elog
- elog "To set a customized Elasticsearch instance:"
- elog " OpenRC: set ES_INSTANCE in /etc/conf.d/${MY_PN}"
- elog " systemd: set elasticsearch.url in /etc/${MY_PN}/kibana.yml"
- elog
- elog "Elasticsearch can run local or remote."
-}