summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-04-30 14:03:43 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2020-05-02 15:11:14 -0700
commit5f3f9ae2abf4a8ab383507246d3faca52d611121 (patch)
treeb49fb37570f5a739d5ab9f24495cf43e501a18a4 /www-apps/mirmon
parentwww-apps/mirmon: cleanup old version (diff)
downloadgentoo-5f3f9ae2abf4a8ab383507246d3faca52d611121.tar.gz
gentoo-5f3f9ae2abf4a8ab383507246d3faca52d611121.tar.bz2
gentoo-5f3f9ae2abf4a8ab383507246d3faca52d611121.zip
www-apps/mirmon: revbump with getopt fixes
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'www-apps/mirmon')
-rw-r--r--www-apps/mirmon/files/2.11-Fix-options.patch34
-rw-r--r--www-apps/mirmon/mirmon-2.11-r2.ebuild (renamed from www-apps/mirmon/mirmon-2.11-r1.ebuild)1
2 files changed, 35 insertions, 0 deletions
diff --git a/www-apps/mirmon/files/2.11-Fix-options.patch b/www-apps/mirmon/files/2.11-Fix-options.patch
new file mode 100644
index 000000000000..0e0924ea9ddc
--- /dev/null
+++ b/www-apps/mirmon/files/2.11-Fix-options.patch
@@ -0,0 +1,34 @@
+Fix option handling.
+
+Add debug option to getopt inputs.
+Add debug option to usage output.
+Add version option to usage output.
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+--- mirmon-2.11.orig/mirmon 2020-04-30 13:32:52.803951845 -0700
++++ mirmon-2.11/mirmon 2020-04-30 13:33:58.051641169 -0700
+@@ -1900,12 +1900,14 @@
+ Usage: $prog [-v] [-q] [-t timeout] [-c conf] [-get all|update|url <url>]
+ option v : be verbose
+ option q : be quiet
++option d : debug output
+ option t : set timeout ; default $TIMEOUT
+ option get : get all : probe all sites
+ : get update : probe a selection of the sites (see doc)
+ : get url <url> : probe some <url> (in the mirror-list).
+ option c : configuration file ; default search :
+ ( $DEF_CNF )
++option version : display version
+ -------------------------------------------------------------------
+ Mirmon normally only reports errors and changes in the mirror list.
+ This is $VERSION.
+@@ -1924,7 +1926,7 @@
+ use Getopt::Long ;
+ Getopt::Long::config ( 'no_ignore_case' ) ;
+ my %opt = () ;
+-Usage '' unless GetOptions ( \%opt, qw(v q t=i get=s c=s version) ) ;
++Usage '' unless GetOptions ( \%opt, qw(d v q t=i get=s c=s version) ) ;
+ Usage "Arg count\n" if @ARGV > 1 ;
+ Usage "Arg count\n" if $opt{get} and $opt{get} eq 'url' and ! @ARGV ;
+
diff --git a/www-apps/mirmon/mirmon-2.11-r1.ebuild b/www-apps/mirmon/mirmon-2.11-r2.ebuild
index 861191e74705..0d6ce1561b0e 100644
--- a/www-apps/mirmon/mirmon-2.11-r1.ebuild
+++ b/www-apps/mirmon/mirmon-2.11-r2.ebuild
@@ -23,6 +23,7 @@ RDEPEND="${DEPEND}
PATCHES=(
"${FILESDIR}/2.11-Add-ipv6-monitor-support-to-mirmon.patch"
+ "${FILESDIR}/2.11-Fix-options.patch"
)
src_install() {