summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/moinmoin/moinmoin-1.9.7-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/moinmoin/moinmoin-1.9.7-r1.ebuild')
-rw-r--r--www-apps/moinmoin/moinmoin-1.9.7-r1.ebuild108
1 files changed, 108 insertions, 0 deletions
diff --git a/www-apps/moinmoin/moinmoin-1.9.7-r1.ebuild b/www-apps/moinmoin/moinmoin-1.9.7-r1.ebuild
new file mode 100644
index 000000000000..66fb239d363a
--- /dev/null
+++ b/www-apps/moinmoin/moinmoin-1.9.7-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit eutils distutils-r1 webapp
+
+MY_PN="moin"
+
+DESCRIPTION="Python WikiClone"
+HOMEPAGE="http://moinmo.in/"
+SRC_URI="http://static.moinmo.in/files/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+
+RDEPEND=">=dev-python/docutils-0.4[${PYTHON_USEDEP}]
+ >=dev-python/flup-1.0.2[${PYTHON_USEDEP}]
+ >=dev-python/pygments-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-0.7.0[${PYTHON_USEDEP}]"
+
+need_httpd_cgi
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+WEBAPP_MANUAL_SLOT="yes"
+
+pkg_setup() {
+ if has_version "<www-apps/moinmoin-1.9" ; then
+ ewarn
+ ewarn "You already have a version of moinmoin prior to 1.9 installed."
+ ewarn "moinmoin-1.9 has a very different configuration than 1.8 (among"
+ ewarn "other changes, static content is no longer installed under the"
+ ewarn "htdocs directory)."
+ ewarn
+ ewarn "Please read http://moinmo.in/MoinMoinRelease1.9 and"
+ ewarn "README.migration in /usr/share/doc/${PF}"
+ ewarn
+ fi
+
+ webapp_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # remove bundled -- parsedatetime and xappy not packaged yet
+ rm -r MoinMoin/support/{pygments,werkzeug,flup} || die
+ sed -i "/\(flup\|pygments\|werkzeug\)/d" setup.py || die
+
+ # needed for python_fix_shebang
+ edos2unix MoinMoin/web/static/htdocs/applets/FCKeditor/editor/filemanager/connectors/py/*.py
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ webapp_src_preinst
+ distutils-r1_src_install
+
+ dodoc README docs/CHANGES* docs/README.migration
+ dohtml docs/INSTALL.html
+ rm -rf README docs/
+
+ cd "${D}"/usr/share/moin
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r server/moin.cgi
+ fperms +x "${MY_HTDOCSDIR}/moin.cgi"
+
+ insinto "${MY_HOSTROOTDIR}"/${PF}
+ doins -r data underlay config/wikiconfig.py
+
+ insinto "${MY_HOSTROOTDIR}"/${PF}/altconfigs
+ doins -r config
+
+ insinto "${MY_HOSTROOTDIR}"/${PF}/altserver
+ doins -r server
+
+ # data needs to be server owned per moin devs
+ cd "${D}/${MY_HOSTROOTDIR}"/${PF}
+ for file in $(find data underlay); do
+ webapp_serverowned "${MY_HOSTROOTDIR}/${PF}/${file}"
+ done
+
+ webapp_configfile "${MY_HOSTROOTDIR}"/${PF}/wikiconfig.py
+ webapp_hook_script "${FILESDIR}"/reconfig-1.9.4
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-1.9.4.txt
+
+ webapp_src_install
+
+ # bug 466390
+ python_fix_shebang "${D}"
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you are upgrading from an older version, please read"
+ ewarn "README.migration in /usr/share/doc/${PF}"
+ ewarn
+
+ distutils_pkg_postinst
+ webapp_pkg_postinst
+}