summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/nanoblogger
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/nanoblogger')
-rw-r--r--www-apps/nanoblogger/Manifest3
-rw-r--r--www-apps/nanoblogger/files/nb.bashcomp48
-rw-r--r--www-apps/nanoblogger/metadata.xml20
-rw-r--r--www-apps/nanoblogger/nanoblogger-3.2.3.ebuild62
-rw-r--r--www-apps/nanoblogger/nanoblogger-3.3.ebuild67
-rw-r--r--www-apps/nanoblogger/nanoblogger-3.5_rc1.ebuild70
6 files changed, 270 insertions, 0 deletions
diff --git a/www-apps/nanoblogger/Manifest b/www-apps/nanoblogger/Manifest
new file mode 100644
index 000000000000..54c000c565e3
--- /dev/null
+++ b/www-apps/nanoblogger/Manifest
@@ -0,0 +1,3 @@
+DIST nanoblogger-3.2.3.tar.gz 54672 SHA256 9b1d51060e9f0f8db7119546c8dbb915c0dd214ed970844705d8738616c9029b
+DIST nanoblogger-3.3.tar.gz 82302 SHA256 b49b25ee18c42dc9cf47fdd456e5dd19033456c64104a0ccba34e318e5daf1a0
+DIST nanoblogger-3.5-rc1.tar.gz 131833 SHA256 78f51b852238adc1cf1287f4a95d56c954fb3dced1a48eb46a0302579428bb26
diff --git a/www-apps/nanoblogger/files/nb.bashcomp b/www-apps/nanoblogger/files/nb.bashcomp
new file mode 100644
index 000000000000..abecda0cb798
--- /dev/null
+++ b/www-apps/nanoblogger/files/nb.bashcomp
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# nanoblogger completion
+# author: Aaron Walker <ka0ttic@gentoo.org>
+
+_nb()
+{
+ local cur prev opts
+ COMPREPLY=()
+ cur="${COMP_WORDS[COMP_CWORD]}"
+ prev="${COMP_WORDS[COMP_CWORD-1]}"
+ opts="-a --add -b --blogdir -B --body -c --category --configure \
+ --datadir -d --delete -D --desc -e --edit -f --blogconf -h --help \
+ -l --list --makepage --manual -m --move -n --author -p --preview \
+ -P --publish --template --templatedir -t --title -u --update \
+ -v --verbose -V --version"
+
+ if [[ "${cur}" == -* || ${COMP_CWORD} -eq 1 ]] ; then
+ COMPREPLY=($(compgen -W "${opts}" -- ${cur}))
+ return 0
+ fi
+
+ case "${prev}" in
+ -b|--*dir)
+ COMPREPLY=($(compgen -d -S '/' -- ${cur}))
+ ;;
+ -f|--blogconf|--template)
+ COMPREPLY=($(compgen -f -- ${cur}))
+ ;;
+ -l|--list)
+ COMPREPLY=($(compgen -W "all cat current max" -- ${cur}))
+ ;;
+ -u|--update)
+ COMPREPLY=($(compgen -W "all current main max" -- ${cur}))
+ ;;
+ ?(-)-@(B|body|c|category|d|delete|D|desc|m|move|n|author|t|title))
+ COMPREPLY=()
+ ;;
+ *)
+ COMPREPLY=($(compgen -W "${opts/${prev}}" -- ${cur}))
+ ;;
+ esac
+}
+complete -F _nb nb
+
+# vim: set ft=sh :
diff --git a/www-apps/nanoblogger/metadata.xml b/www-apps/nanoblogger/metadata.xml
new file mode 100644
index 000000000000..194b9f320e11
--- /dev/null
+++ b/www-apps/nanoblogger/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>web-apps</herd>
+ <longdescription lang="en">
+Nanoblogger is a small weblog engine written in Bash for the command line. It
+uses common UNIX tools such as cat, grep, and sed. Features include: support
+for multiple weblogs, support for multiple categories, archiving by category,
+entry, and month, pagination, permanent links, RSS syndication (1.0 and 2.0),
+Atom syndication (0.3), templates and CSS style sheets for full control over
+appearance, placeholders for easy template manipulation, plugins for calendar,
+recent entries, weblog status, fortunes, etc, auto-formatting of HTML, support
+for relative and absolute links, per-weblog configuration, simple cache system
+for faster content generation, auto-detection of weblog by current directory, no
+database dependencies (uses flat-file), and mutliplatform portability.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">nanoblogger</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-apps/nanoblogger/nanoblogger-3.2.3.ebuild b/www-apps/nanoblogger/nanoblogger-3.2.3.ebuild
new file mode 100644
index 000000000000..285ef7abb81f
--- /dev/null
+++ b/www-apps/nanoblogger/nanoblogger-3.2.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit bash-completion-r1
+
+DESCRIPTION="Small and simple weblog engine written in Bash for the command-line"
+HOMEPAGE="http://nanoblogger.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ia64 ~mips ppc x86"
+IUSE=""
+
+RDEPEND="app-shells/bash"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's|^\(NB_BASE_DIR=\).*$|\1"/usr/share/nanoblogger"|' \
+ -e 's|"$NB_BASE_DIR/\(nb\.conf\)"|"/etc/\1"|g' \
+ -e "s|\$NB_BASE_DIR.*\(nano.*html\)|/usr/share/doc/${PF}/html/\1|" \
+ nb || die "sed nb failed"
+}
+
+src_install() {
+ dobin nb
+ insinto /usr/share/nanoblogger
+ doins -r default moods plugins
+ insinto /etc
+ doins nb.conf
+ dodoc ChangeLog
+ dohtml docs/nanoblogger.html
+ dobashcomp "${FILESDIR}"/nb.bashcomp || die
+}
+
+pkg_postinst() {
+ elog
+ elog "Documentation for getting started with nanoblogger may be found at"
+ elog "/usr/share/doc/${PF}/html/nanoblogger.html or by running 'nb --manual;."
+ elog
+ elog "To create and configure a new weblog, run the following as your user:"
+ elog " nb -b /some/dir -a"
+ elog "where /some/dir is a directory that DOES NOT exist."
+ elog
+ elog "To prevent having to specify your blog directory every time you use"
+ elog "nanoblogger (with the -b switch), you can set a default value in your"
+ elog "~/.nb.conf. For example:"
+ elog ' BLOG_DIR="$HOME/public_html/blog"'
+ elog
+ elog "If you are upgrading nanoblogger from a previous version, follow"
+ elog "these directions (as stated in the manual):"
+ elog " 1. create a new weblog directory using nanoblogger (skip configuration):"
+ elog " nb [-b blog_dir] -a"
+ elog " 2. copy old data directry to new weblog:"
+ elog " cp -r [old_blog_dir]/data [newblog_dir]"
+ elog " 3. edit new blog.conf to your liking and rebuild weblog:"
+ elog " nb [-b blog_dir] --configure -u all"
+ elog
+}
diff --git a/www-apps/nanoblogger/nanoblogger-3.3.ebuild b/www-apps/nanoblogger/nanoblogger-3.3.ebuild
new file mode 100644
index 000000000000..ae97ed1aea73
--- /dev/null
+++ b/www-apps/nanoblogger/nanoblogger-3.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit bash-completion-r1
+
+DESCRIPTION="Small and simple weblog engine written in Bash for the command-line"
+HOMEPAGE="http://nanoblogger.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~x86"
+IUSE=""
+
+RDEPEND="app-shells/bash"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's|^\(NB_BASE_DIR=\).*$|\1"/usr/share/nanoblogger"|' \
+ -e 's|^\(NB_CFG_DIR=\).*$|\1"/etc"|' \
+ -e "s|\$NB_BASE_DIR.*\(nano.*html\)|/usr/share/doc/${PF}/html/\1|" \
+ nb || die "sed nb failed"
+}
+
+src_install() {
+ dobin nb
+ insinto /usr/share/nanoblogger
+ doins -r default moods plugins lib lang docs welcome-to-nb.txt
+ insinto /etc
+ doins nb.conf
+ dodoc ChangeLog
+ dohtml docs/nanoblogger.html
+ dobashcomp "${FILESDIR}"/nb.bashcomp || die
+}
+
+pkg_postinst() {
+ elog
+ elog "Documentation for getting started with nanoblogger may be found at"
+ elog "/usr/share/doc/${PF}/html/nanoblogger.html or by running 'nb --manual;."
+ elog
+ elog "To create and configure a new weblog, run the following as your user:"
+ elog " nb -b /some/dir -a"
+ elog "where /some/dir is a directory that DOES NOT exist."
+ elog
+ elog "To prevent having to specify your blog directory every time you use"
+ elog "nanoblogger (with the -b switch), you can set a default value in your"
+ elog "~/.nb.conf. For example:"
+ elog ' BLOG_DIR="$HOME/public_html/blog"'
+ elog
+ elog "If you are upgrading nanoblogger from a previous version, follow"
+ elog "these directions (as stated in the manual):"
+ elog " 1. create a new weblog directory using nanoblogger (skip configuration):"
+ elog " nb [-b blog_dir] -a"
+ elog " 2. copy old data directry to new weblog:"
+ elog " cp -r [old_blog_dir]/data [newblog_dir]"
+ elog " 3. edit new blog.conf to your liking and rebuild weblog:"
+ elog " nb [-b blog_dir] --configure -u all"
+ elog
+ elog "You also should remove your [newblog_dir]/data/cat_1.db and run:"
+ elog " nb -u all"
+ elog "after copying your old entries from [oldblog_dir]/data to"
+ elog "[newblog_dir]/data."
+ elog
+}
diff --git a/www-apps/nanoblogger/nanoblogger-3.5_rc1.ebuild b/www-apps/nanoblogger/nanoblogger-3.5_rc1.ebuild
new file mode 100644
index 000000000000..3de73e43bb79
--- /dev/null
+++ b/www-apps/nanoblogger/nanoblogger-3.5_rc1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit bash-completion-r1
+
+MY_P="${P/_/-}"
+DESCRIPTION="Small and simple weblog engine written in Bash for the command-line"
+HOMEPAGE="http://nanoblogger.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~x86"
+IUSE=""
+
+RDEPEND="app-shells/bash"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i \
+ -e 's|^\(NB_BASE_DIR=\).*$|\1"/usr/share/nanoblogger"|' \
+ -e 's|^\(NB_CFG_DIR=\).*$|\1"/etc"|' \
+ -e "s|\$NB_BASE_DIR.*\(nano.*html\)|/usr/share/doc/${PF}/html/\1|" \
+ nb || die "sed nb failed"
+}
+
+src_install() {
+ dobin nb
+ insinto /usr/share/nanoblogger
+ doins -r default moods plugins lib lang docs welcome-to-nb.txt
+ insinto /etc
+ doins nb.conf
+ dodoc ChangeLog
+ dohtml docs/nanoblogger.html
+ dobashcomp "${FILESDIR}"/nb.bashcomp
+}
+
+pkg_postinst() {
+ elog
+ elog "Documentation for getting started with nanoblogger may be found at"
+ elog "/usr/share/doc/${PF}/html/nanoblogger.html or by running 'nb --manual;."
+ elog
+ elog "To create and configure a new weblog, run the following as your user:"
+ elog " nb -b /some/dir -a"
+ elog "where /some/dir is a directory that DOES NOT exist."
+ elog
+ elog "To prevent having to specify your blog directory every time you use"
+ elog "nanoblogger (with the -b switch), you can set a default value in your"
+ elog "~/.nb.conf. For example:"
+ elog ' BLOG_DIR="$HOME/public_html/blog"'
+ elog
+ elog "If you are upgrading nanoblogger from a previous version, follow"
+ elog "these directions (as stated in the manual):"
+ elog " 1. create a new weblog directory using nanoblogger (skip configuration):"
+ elog " nb [-b blog_dir] -a"
+ elog " 2. copy old data directry to new weblog:"
+ elog " cp -r [old_blog_dir]/data [newblog_dir]"
+ elog " 3. edit new blog.conf to your liking and rebuild weblog:"
+ elog " nb [-b blog_dir] --configure -u all"
+ elog
+ elog "You also should remove your [newblog_dir]/data/cat_1.db and run:"
+ elog " nb -u all"
+ elog "after copying your old entries from [oldblog_dir]/data to"
+ elog "[newblog_dir]/data."
+ elog
+}